summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:17:40 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:35 +0100
commit5354073d95b5d407ad5ae198e2e9ca96847cd35d (patch)
tree0f485047fefd973fd99b00cf169daeb665fcdb11 /dev-lua/lua-argparse
parentdev-lua/lanes: drop 3.15.1 (diff)
downloadgentoo-5354073d95b5d407ad5ae198e2e9ca96847cd35d.tar.gz
gentoo-5354073d95b5d407ad5ae198e2e9ca96847cd35d.tar.bz2
gentoo-5354073d95b5d407ad5ae198e2e9ca96847cd35d.zip
dev-lua/lua-argparse: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/lua-argparse')
-rw-r--r--dev-lua/lua-argparse/lua-argparse-0.7.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-lua/lua-argparse/lua-argparse-0.7.1-r1.ebuild b/dev-lua/lua-argparse/lua-argparse-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..a5ec5f1a7f61
--- /dev/null
+++ b/dev-lua/lua-argparse/lua-argparse-0.7.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Feature-rich command line parser for Lua"
+HOMEPAGE="https://github.com/luarocks/argparse"
+SRC_URI="https://github.com/luarocks/${PN/lua-/}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN//lua-/}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+lua_src_install() {
+ insinto "$(lua_get_lmod_dir)"
+ doins src/argparse.lua
+}
+
+src_install() {
+ default
+ lua_foreach_impl lua_src_install
+}