summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:21:02 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:39 +0100
commit70cc2638fb1b52467a7188bc5ac7e32589150efd (patch)
tree78f72ad78f2f0e916aae0ba0f81f64c587643133 /dev-lua/lua-utf8/lua-utf8-0.1.3-r1.ebuild
parentdev-lua/lua-term: drop 0.7-r101 (diff)
downloadgentoo-70cc2638fb1b52467a7188bc5ac7e32589150efd.tar.gz
gentoo-70cc2638fb1b52467a7188bc5ac7e32589150efd.tar.bz2
gentoo-70cc2638fb1b52467a7188bc5ac7e32589150efd.zip
dev-lua/lua-utf8: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/lua-utf8/lua-utf8-0.1.3-r1.ebuild')
-rw-r--r--dev-lua/lua-utf8/lua-utf8-0.1.3-r1.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/dev-lua/lua-utf8/lua-utf8-0.1.3-r1.ebuild b/dev-lua/lua-utf8/lua-utf8-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..b219355d088d
--- /dev/null
+++ b/dev-lua/lua-utf8/lua-utf8-0.1.3-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="A UTF-8 support module for Lua and LuaJIT"
+HOMEPAGE="https://github.com/starwing/luautf8"
+SRC_URI="https://github.com/starwing/luautf8/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN//-/}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+lua_src_compile() {
+ local compiler=(
+ "$(tc-getCC)"
+ "${CFLAGS}"
+ "-fPIC"
+ "${LDFLAGS}"
+ "$(lua_get_CFLAGS)"
+ "-c lutf8lib.c"
+ "-o lutf8lib-${ELUA}.o"
+ )
+ einfo "${compiler[@]}"
+ ${compiler[@]} || die
+
+ local linker=(
+ "$(tc-getCC)"
+ "-shared"
+ "${LDFLAGS}"
+ "-o lutf8lib-${ELUA}.so"
+ "lutf8lib-${ELUA}.o"
+ )
+ einfo "${linker[@]}"
+ ${linker[@]} || die
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_test() {
+ local mytests=(
+ "test.lua"
+ "test_compat.lua"
+ "test_pm.lua"
+ )
+
+ for mytest in ${mytests[@]}; do
+ LUA_CPATH="${S}/lutf8lib-${ELUA}.so" ${ELUA} ${mytest} || die
+ done
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ exeinto "$(lua_get_cmod_dir)"
+ newexe "lutf8lib-${ELUA}.so" "lua-utf8.so"
+
+ insinto "$(lua_get_lmod_dir)"
+ doins parseucd.lua
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}