summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Misbakh-Soloviov <mva@gentoo.org>2021-09-26 05:46:19 +0700
committerVadim Misbakh-Soloviov <mva@gentoo.org>2021-09-26 05:56:47 +0700
commita9dcb35859e3573e7030ebc9141c9517316fcccd (patch)
tree543c75744aa5ff309108fbc3e3d635c80fd85f3d /dev-lua/lua-utf8
parentapp-emulation/q4wine: new version (diff)
downloadgentoo-a9dcb35859e3573e7030ebc9141c9517316fcccd.tar.gz
gentoo-a9dcb35859e3573e7030ebc9141c9517316fcccd.tar.bz2
gentoo-a9dcb35859e3573e7030ebc9141c9517316fcccd.zip
dev-lua/lua-utf8: fix ucd data header regeneration
Package-Manager: Portage-3.0.23, Repoman-3.0.1 Signed-off-by: Vadim Misbakh-Soloviov <mva@gentoo.org>
Diffstat (limited to 'dev-lua/lua-utf8')
-rw-r--r--dev-lua/lua-utf8/lua-utf8-0.1.3-r101.ebuild102
1 files changed, 102 insertions, 0 deletions
diff --git a/dev-lua/lua-utf8/lua-utf8-0.1.3-r101.ebuild b/dev-lua/lua-utf8/lua-utf8-0.1.3-r101.ebuild
new file mode 100644
index 000000000000..56443c4373a5
--- /dev/null
+++ b/dev-lua/lua-utf8/lua-utf8-0.1.3-r101.ebuild
@@ -0,0 +1,102 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="A UTF-8 support module for Lua and LuaJIT"
+HOMEPAGE="https://github.com/starwing/luautf8"
+SRC_URI="https://github.com/starwing/luautf8/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN//-/}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ ${LUA_DEPS}
+"
+
+src_prepare() {
+ local unicodedir="${EPREFIX}"/usr/share/unicode
+ local ucddir
+
+ if has_verson '<app-i18n/unicode-data-14.0.0-r1'; then
+ ucddir="${unicodedir}-data"
+ else
+ ucddir=${unicodedir}
+ fi
+
+ sed -i \
+ -e "s@UCD/@${ucd}/@" \
+ parseucd.lua
+
+ default
+}
+
+lua_src_compile() {
+ einfo "Performing regeneration unicode data header against app-i18n/unicode-data with ${ELUA}"
+ "${ELUA}" parseucd.lua
+
+ local compiler=(
+ "$(tc-getCC)"
+ "${CFLAGS}"
+ "-fPIC"
+ "${LDFLAGS}"
+ "$(lua_get_CFLAGS)"
+ "-c lutf8lib.c"
+ "-o lutf8lib-${ELUA}.o"
+ )
+ einfo "${compiler[@]}"
+ ${compiler[@]} || die
+
+ local linker=(
+ "$(tc-getCC)"
+ "-shared"
+ "${LDFLAGS}"
+ "-o lutf8lib-${ELUA}.so"
+ "lutf8lib-${ELUA}.o"
+ )
+ einfo "${linker[@]}"
+ ${linker[@]} || die
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_test() {
+ local mytests=(
+ "test.lua"
+ "test_compat.lua"
+ "test_pm.lua"
+ )
+
+ for mytest in ${mytests[@]}; do
+ LUA_CPATH="${S}/lutf8lib-${ELUA}.so" ${ELUA} ${mytest} || die
+ done
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ exeinto "$(lua_get_cmod_dir)"
+ newexe "lutf8lib-${ELUA}.so" "lua-utf8.so"
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}