summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-10-06 01:05:59 +0300
committerConrad Kostecki <conikost@gentoo.org>2020-10-08 21:13:41 +0200
commitf8051ee00cc653d5e43febbf00b05dc24959ee8c (patch)
tree1d8f17aa96ccdba9c28ae82f3b1e6348ebf60a31 /dev-lua/luaexpat/luaexpat-1.3.3-r2.ebuild
parentdev-libs/libotf: Stabilize 0.9.16 amd64, #747349 (diff)
downloadgentoo-f8051ee00cc653d5e43febbf00b05dc24959ee8c.tar.gz
gentoo-f8051ee00cc653d5e43febbf00b05dc24959ee8c.tar.bz2
gentoo-f8051ee00cc653d5e43febbf00b05dc24959ee8c.zip
dev-lua/luaexpat: restore more functionality
Restore more features that sill missed in forked 1.3.3 See: https://github.com/tomasguisasola/luaexpat/pull/5 Closes: https://github.com/gentoo/gentoo/pull/17813 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/luaexpat/luaexpat-1.3.3-r2.ebuild')
-rw-r--r--dev-lua/luaexpat/luaexpat-1.3.3-r2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-lua/luaexpat/luaexpat-1.3.3-r2.ebuild b/dev-lua/luaexpat/luaexpat-1.3.3-r2.ebuild
new file mode 100644
index 000000000000..5b99b5d96bac
--- /dev/null
+++ b/dev-lua/luaexpat/luaexpat-1.3.3-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal toolchain-funcs
+
+DESCRIPTION="LuaExpat is a SAX XML parser based on the Expat library"
+HOMEPAGE="https://matthewwild.co.uk/projects/luaexpat/ https://github.com/tomasguisasola/luaexpat"
+SRC_URI="https://github.com/tomasguisasola/luaexpat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=dev-lang/lua-5.1.5-r2:0[${MULTILIB_USEDEP}]
+ >=dev-libs/expat-2.1.0-r3[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}_makefile.patch"
+ "${FILESDIR}/${P}_getcurrentbytecount.patch"
+ "${FILESDIR}/${P}_restore_functionality.patch"
+)
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ LUA_INC="$($(tc-getPKG_CONFIG) --variable INSTALL_INC lua)"
+}
+
+multilib_src_install() {
+ emake \
+ LUA_DIR="${D}/$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)" \
+ LUA_LIBDIR="${D}/$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)" \
+ install
+}
+
+multilib_src_install_all() {
+ dodoc -r README.md doc/*
+}