summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-03-15 16:54:13 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-03-15 16:54:13 -0700
commit67daf2dadfee0b73600089cac26ad359c054e967 (patch)
treeeb619ca435ec19e037bd248e3b23ab39617562c5 /dev-lua/luafilesystem/luafilesystem-1.7.0.2.ebuild
parentdev-lua/luafilesystem: version bump to 1.7.0.2 (diff)
downloadgentoo-67daf2dadfee0b73600089cac26ad359c054e967.tar.gz
gentoo-67daf2dadfee0b73600089cac26ad359c054e967.tar.bz2
gentoo-67daf2dadfee0b73600089cac26ad359c054e967.zip
dev-lua/luafilesystem: QA: fix flag handling, add doc useflag
restore ~sparc keyword Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lua/luafilesystem/luafilesystem-1.7.0.2.ebuild')
-rw-r--r--dev-lua/luafilesystem/luafilesystem-1.7.0.2.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-lua/luafilesystem/luafilesystem-1.7.0.2.ebuild b/dev-lua/luafilesystem/luafilesystem-1.7.0.2.ebuild
index c6f529263025..88b4ef4b5a98 100644
--- a/dev-lua/luafilesystem/luafilesystem-1.7.0.2.ebuild
+++ b/dev-lua/luafilesystem/luafilesystem-1.7.0.2.ebuild
@@ -8,12 +8,12 @@ MY_PV=${PV//./_}
DESCRIPTION="File System Library for the Lua Programming Language"
HOMEPAGE="https://keplerproject.github.io/luafilesystem/"
-SRC_URI="https://github.com/keplerproject/luafilesystem/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/keplerproject/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~x86"
-IUSE="luajit test"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc luajit test"
RESTRICT="!test? ( test )"
@@ -42,15 +42,15 @@ src_configure() {
LUA_INC+=-I$($(tc-getPKG_CONFIG) --variable includedir $(usex luajit 'luajit' 'lua'))
# OS dependent
- LIB_OPTION=-shared #for Linux
+ LIB_OPTION=\$(LDFLAGS) -shared
LIBNAME=$T.so.$V
# Compilation directives
WARN=-O2 -Wall -fPIC -W -Waggregate-return -Wcast-align -Wmissing-prototypes -Wnested-externs -Wshadow -Wwrite-strings -pedantic
INCS=\$(LUA_INC)
- CFLAGS=\$(WARN) \$(INCS)
- CC=gcc
+ CFLAGS+=\$(WARN) \$(INCS)
+ CC=$(tc-getCC)
EOF
}
@@ -59,7 +59,7 @@ src_test() {
}
src_install() {
- local -a HTML_DOCS=( doc/us )
+ use doc && local HTML_DOCS=( doc/us/. )
einstalldocs
emake DESTDIR="${D}" install