summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2016-11-06 16:17:40 +0100
committerRafael Martins <rafaelmartins@gentoo.org>2016-11-06 16:18:08 +0100
commitc4ecb3a9ab59464a8a80a00b432d4a4778210aa6 (patch)
tree761537a922252cd9c8f534d55500855088c01fe9 /dev-lua/luasec/luasec-0.6.ebuild
parentkde-apps/kdepimlibs: make configure not die (diff)
downloadgentoo-c4ecb3a9ab59464a8a80a00b432d4a4778210aa6.tar.gz
gentoo-c4ecb3a9ab59464a8a80a00b432d4a4778210aa6.tar.bz2
gentoo-c4ecb3a9ab59464a8a80a00b432d4a4778210aa6.zip
dev-lua/luasec: version bump (bug #595628)
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-lua/luasec/luasec-0.6.ebuild')
-rw-r--r--dev-lua/luasec/luasec-0.6.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-lua/luasec/luasec-0.6.ebuild b/dev-lua/luasec/luasec-0.6.ebuild
new file mode 100644
index 000000000000..3a1f33912bc0
--- /dev/null
+++ b/dev-lua/luasec/luasec-0.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib toolchain-funcs eutils
+
+DESCRIPTION="Lua binding for OpenSSL library to provide TLS/SSL communication"
+HOMEPAGE="https://github.com/brunoos/luasec http://www.inf.puc-rio.br/~brunoos/luasec/"
+SRC_URI="https://github.com/brunoos/luasec/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="libressl"
+
+RDEPEND="
+ >=dev-lang/lua-5.1:0[deprecated]
+ dev-lua/luasocket
+ !libressl? ( dev-libs/openssl:0 ) libressl? ( dev-libs/libressl:= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}-${P}
+
+src_prepare() {
+ sed -i -e "s/-O2//" src/Makefile || die
+ lua src/options.lua -g /usr/include/openssl/ssl.h > src/options.h || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ linux
+}
+
+src_install() {
+ emake \
+ LUAPATH="${D}/$(pkg-config --variable INSTALL_LMOD lua)" \
+ LUACPATH="${D}/$(pkg-config --variable INSTALL_CMOD lua)" \
+ install
+}