summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:36:55 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:53 +0100
commit2d6e066eae4d7b792b4cbf420606d3d071833eab (patch)
tree45e14fe17640007af83feca01c0e36dc102324da /dev-lua/mediator_lua
parentdev-lua/luasystem: drop 0.2.1_p0-r102 (diff)
downloadgentoo-2d6e066eae4d7b792b4cbf420606d3d071833eab.tar.gz
gentoo-2d6e066eae4d7b792b4cbf420606d3d071833eab.tar.bz2
gentoo-2d6e066eae4d7b792b4cbf420606d3d071833eab.zip
dev-lua/mediator_lua: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/mediator_lua')
-rw-r--r--dev-lua/mediator_lua/mediator_lua-1.1.2_p0-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-lua/mediator_lua/mediator_lua-1.1.2_p0-r1.ebuild b/dev-lua/mediator_lua/mediator_lua-1.1.2_p0-r1.ebuild
new file mode 100644
index 000000000000..a43883a261ae
--- /dev/null
+++ b/dev-lua/mediator_lua/mediator_lua-1.1.2_p0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+MY_PV="${PV/_p/-}"
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Mediator pattern implementation for pub-sub management"
+HOMEPAGE="http://olivinelabs.com/mediator_lua/"
+SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="${LUA_DEPS}"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-lua/busted[${LUA_USEDEP}]
+ dev-lua/lua_cliargs[${LUA_USEDEP}]
+ ${RDEPEND}
+ )
+"
+
+lua_src_test() {
+ busted --lua=${ELUA} || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ insinto $(lua_get_lmod_dir)
+ doins src/mediator.lua
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}