summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-12-04 18:11:06 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-12-04 18:13:56 +0100
commit21a6badef560bf8bd3e995f38886d55b1851d95b (patch)
tree3db7a7d8a8b3e9e785d1945eb9fde182ee0d500a /dev-lua/messagepack/messagepack-0.5.2_p20201025-r100.ebuild
parentdev-lua/messagepack: bump to version 0.5.2 (diff)
downloadgentoo-21a6badef560bf8bd3e995f38886d55b1851d95b.tar.gz
gentoo-21a6badef560bf8bd3e995f38886d55b1851d95b.tar.bz2
gentoo-21a6badef560bf8bd3e995f38886d55b1851d95b.zip
dev-lua/messagepack: bump to version 0.5.2 (slotted lua)
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/messagepack/messagepack-0.5.2_p20201025-r100.ebuild')
-rw-r--r--dev-lua/messagepack/messagepack-0.5.2_p20201025-r100.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-lua/messagepack/messagepack-0.5.2_p20201025-r100.ebuild b/dev-lua/messagepack/messagepack-0.5.2_p20201025-r100.ebuild
new file mode 100644
index 000000000000..4dc5d4b18fc3
--- /dev/null
+++ b/dev-lua/messagepack/messagepack-0.5.2_p20201025-r100.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT="18f316b3f62c02bf2b7a3096701780f78a4d2c67"
+LUA_COMPAT=( lua5-{1..2} luajit )
+MY_PN="lua-MessagePack"
+MY_P="${MY_PN}-${EGIT_COMMIT}"
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="A pure Lua implementation of the MessagePack serialization format"
+HOMEPAGE="https://fperrad.frama.io/lua-MessagePack"
+SRC_URI="https://framagit.org/fperrad/${MY_PN}/-/archive/${EGIT_COMMIT}/${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+# Needed 'lua-TestMore' Lua module not in tree
+RESTRICT="test"
+
+RDEPEND="${LUA_DEPS}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( ${RDEPEND} )
+"
+
+src_compile() {
+ :;
+}
+
+lua_src_install() {
+ local myemakeargs=(
+ "LIBDIR=${ED}/$(lua_get_lmod_dir)"
+ "LUAVER=$(ver_cut 1-2 $(lua_get_version))"
+ )
+
+ emake "${myemakeargs[@]}" install
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}