summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-28 18:28:13 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-28 18:44:46 +0100
commitd092e2552d46e5abd728bc5753d9019fd3f3d0ca (patch)
tree17c977f1bdb63f51e2d580dfbae33420f9a3dff3 /dev-lua/penlight/penlight-1.9.2-r101.ebuild
parentdev-lua/mediator_lua: drop old version (diff)
downloadgentoo-d092e2552d46e5abd728bc5753d9019fd3f3d0ca.tar.gz
gentoo-d092e2552d46e5abd728bc5753d9019fd3f3d0ca.tar.bz2
gentoo-d092e2552d46e5abd728bc5753d9019fd3f3d0ca.zip
dev-lua/penlight: fix lua deps
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/penlight/penlight-1.9.2-r101.ebuild')
-rw-r--r--dev-lua/penlight/penlight-1.9.2-r101.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-lua/penlight/penlight-1.9.2-r101.ebuild b/dev-lua/penlight/penlight-1.9.2-r101.ebuild
new file mode 100644
index 000000000000..fc399a4a51d6
--- /dev/null
+++ b/dev-lua/penlight/penlight-1.9.2-r101.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+MY_PN="Penlight"
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Lua utility libraries loosely based on the Python standard libraries"
+HOMEPAGE="https://github.com/Tieske/Penlight",
+SRC_URI="https://github.com/Tieske/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+DEPEND="${LUA_DEPS}"
+
+RDEPEND="
+ >=dev-lua/luafilesystem-1.8.0-r100
+ ${DEPEND}
+"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? ( ${DEPEND} )
+"
+
+HTML_DOCS=( "docs/." )
+
+lua_src_test() {
+ ${ELUA} run.lua || die
+}
+
+src_test() {
+ # This is a demo app, not a real test
+ rm tests/test-app.lua
+
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ insinto $(lua_get_lmod_dir)
+ doins -r lua/pl
+
+ einstalldocs
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}