summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-28 18:44:24 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-28 18:44:53 +0100
commit05cc84c123b3edd6f1e7ae173c0d9422aefda658 (patch)
tree7d455938f7e1784784410d7181699957a0b6b490 /dev-lua/penlight
parentdev-lua/luasec: drop old version (diff)
downloadgentoo-05cc84c123b3edd6f1e7ae173c0d9422aefda658.tar.gz
gentoo-05cc84c123b3edd6f1e7ae173c0d9422aefda658.tar.bz2
gentoo-05cc84c123b3edd6f1e7ae173c0d9422aefda658.zip
dev-lua/penlight: bump to version 1.9.2
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/penlight')
-rw-r--r--dev-lua/penlight/penlight-1.9.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-lua/penlight/penlight-1.9.2.ebuild b/dev-lua/penlight/penlight-1.9.2.ebuild
new file mode 100644
index 000000000000..a679ab743c3a
--- /dev/null
+++ b/dev-lua/penlight/penlight-1.9.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="Penlight"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lua utility libraries loosely based on the Python standard libraries"
+HOMEPAGE="https://github.com/Tieske/Penlight",
+SRC_URI="https://github.com/Tieske/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=dev-lang/lua-5.1:="
+
+RDEPEND="
+ dev-lua/luafilesystem
+ ${DEPEND}
+"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? ( ${DEPEND} )
+"
+
+HTML_DOCS=( "docs/." )
+
+src_test() {
+ # This is a demo app, not a real test
+ rm tests/test-app.lua
+
+ lua run.lua || die
+}
+
+src_install() {
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
+ doins -r lua/pl
+
+ einstalldocs
+}