summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-12-02 00:44:17 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-12-02 00:53:54 +0100
commit03a1bee2fc2e190d8ba765bd46cdb1f95caa3804 (patch)
tree1347be5bb42d61c4168e8b5aa0dc4143a79c6307 /dev-lua
parentnet-dns/nsd: Removed old (diff)
downloadgentoo-03a1bee2fc2e190d8ba765bd46cdb1f95caa3804.tar.gz
gentoo-03a1bee2fc2e190d8ba765bd46cdb1f95caa3804.tar.bz2
gentoo-03a1bee2fc2e190d8ba765bd46cdb1f95caa3804.zip
dev-lua/lualdap: bump to version 1.2.5
This version switches back to a more active repo. Thanks to the work of winterheart with some changes. Closes: https://bugs.gentoo.org/693540 Closes: https://bugs.gentoo.org/723164 Closes: https://github.com/gentoo/gentoo/pull/17491 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/lualdap/Manifest1
-rw-r--r--dev-lua/lualdap/lualdap-1.2.5.ebuild58
-rw-r--r--dev-lua/lualdap/metadata.xml7
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-lua/lualdap/Manifest b/dev-lua/lualdap/Manifest
index 727dc31550e3..05a2c71f545f 100644
--- a/dev-lua/lualdap/Manifest
+++ b/dev-lua/lualdap/Manifest
@@ -1 +1,2 @@
DIST lualdap-1.2.0.tar.xz 12380 BLAKE2B 42bf8633a5ccd60f6082b8729b9ba77c8f5486a7bab6cf727fc011856fec244de9f0fa96dd53c23a3fb5932a1670bbb621739c965618671c2c856c41e3faffbb SHA512 02cd3089dc6ca1f60957fa4733dae3cbfb2e13c25b068ddeb51b059701278eb86e359d56a6ef1df28cf514193311323255b36ff036bafda9fcbae0676d90a238
+DIST lualdap-1.2.5.tar.gz 85920 BLAKE2B 14015fe258fa391e08fc9b6bdb7a71dae10fbd84636cc3d84c446d67f9d0ea925c0086343a29ce21b81f77c87da37040560c631cdf3df7c8d3c255e5913fd985 SHA512 4fbd7bcea2e55a3b165a7316e4f6c45aee22506915c4cc204d1b5006adbf95611ebf4558c1ef1511f90d7142571cff37ea24952072dc7ecb13bbbe06aef32e72
diff --git a/dev-lua/lualdap/lualdap-1.2.5.ebuild b/dev-lua/lualdap/lualdap-1.2.5.ebuild
new file mode 100644
index 000000000000..9d530b5b471e
--- /dev/null
+++ b/dev-lua/lualdap/lualdap-1.2.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A lua binding for the OpenLDAP client libraries"
+HOMEPAGE="https://github.com/lualdap/lualdap"
+SRC_URI="https://github.com/lualdap/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="luajit test"
+RESTRICT="test"
+
+RDEPEND="
+ luajit? ( dev-lang/luajit:2 )
+ !luajit? ( dev-lang/lua:0 )
+ net-nds/openldap
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( ${RDEPEND} )
+"
+
+HTML_DOCS=( "doc/us/." )
+
+src_compile() {
+ local myemakeargs=(
+ "CC=$(tc-getCC)"
+ "LBER_LIBDIR=/usr/$(get_libdir)"
+ "LDAP_LIBDIR=/usr/$(get_libdir)"
+ "LUA_INCDIR=$($(tc-getPKG_CONFIG) --variable includedir $(usex luajit 'luajit' 'lua'))"
+ )
+
+ emake "${myemakeargs[@]}"
+}
+
+src_test() {
+ LUA_CPATH="${S}/src/?.so" $(usex luajit 'luajit' 'lua') tests/test.lua
+}
+
+src_install() {
+ # Workaround, as 'make install' does not create this directory
+ dodir "$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD $(usex luajit 'luajit' 'lua'))"
+
+ local myemakeargs=(
+ "DESTDIR=${ED}"
+ "INST_LIBDIR=$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD $(usex luajit 'luajit' 'lua'))"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ einstalldocs
+}
diff --git a/dev-lua/lualdap/metadata.xml b/dev-lua/lualdap/metadata.xml
index 485a025884ba..aa61238027f4 100644
--- a/dev-lua/lualdap/metadata.xml
+++ b/dev-lua/lualdap/metadata.xml
@@ -9,4 +9,11 @@
<email>zx2c4@gentoo.org</email>
<name>Jason A. Donenfeld</name>
</maintainer>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lualdap/lualdap</remote-id>
+ </upstream>
</pkgmetadata>