summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-03-16 17:54:38 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-03-16 18:28:38 +0100
commit186ba7216e330c750553b926ee055e5d7c00acda (patch)
tree23eee509776bc24878611ac423da73bca8a5b2f0 /dev-lua
parentdev-lua/busted: add lua5-4 support (diff)
downloadgentoo-186ba7216e330c750553b926ee055e5d7c00acda.tar.gz
gentoo-186ba7216e330c750553b926ee055e5d7c00acda.tar.bz2
gentoo-186ba7216e330c750553b926ee055e5d7c00acda.zip
dev-lua/luacheck: bump to version 0.24.0
This release also adds lua5-4 support and tests passed for me. Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luacheck/Manifest1
-rw-r--r--dev-lua/luacheck/luacheck-0.24.0.ebuild65
-rw-r--r--dev-lua/luacheck/metadata.xml6
3 files changed, 70 insertions, 2 deletions
diff --git a/dev-lua/luacheck/Manifest b/dev-lua/luacheck/Manifest
index 926e7bc8573a..569a64237db6 100644
--- a/dev-lua/luacheck/Manifest
+++ b/dev-lua/luacheck/Manifest
@@ -1 +1,2 @@
DIST luacheck-0.23.0.tar.gz 158201 BLAKE2B c0780143a335b1deb7725819dbdac03446742fd459eed5a6de0cf3de5576f3be5379ff7086348b8880eba70dd5f7a1e719e9a09fdcc70abc293e1636f575ad57 SHA512 d76e4b22f1e9d868a8531ad51fb98607e5bfb1fbbd55053105d9978ba6c0455de99202c53d4e199733ea997863b26527fb84e7e9717209fd588f1d02db9db028
+DIST luacheck-0.24.0.tar.gz 162474 BLAKE2B 6ec2b35deb2f0e5dacbe00e9d5adda7a1d66ee55475adf2b40cfff4d876cd44c9aec762e52bf02bb6f65cccc7c42203d94d3c9ed7a9f2311b3b7ae7bf8ab09e0 SHA512 759079d4a033c8af1d7c314f39bb75398b8ad89b627eaf8b60cf0a878c3ea86bd5e8993ad3d564746614b06b93b4100f016fdcb805d02b226e8e1e5b4c81c6d2
diff --git a/dev-lua/luacheck/luacheck-0.24.0.ebuild b/dev-lua/luacheck/luacheck-0.24.0.ebuild
new file mode 100644
index 000000000000..d84d6ffe301a
--- /dev/null
+++ b/dev-lua/luacheck/luacheck-0.24.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="A tool for linting and static analysis of Lua code"
+HOMEPAGE="https://github.com/luarocks/luacheck"
+SRC_URI="https://github.com/luarocks/luacheck/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lua/lua-argparse[${LUA_USEDEP}]
+ dev-lua/lua-utf8[${LUA_USEDEP}]
+ dev-lua/luafilesystem[${LUA_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )
+ test? (
+ dev-lua/busted[${LUA_USEDEP}]
+ ${RDEPEND}
+ )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0.23.0-disable-measuring-performance-test.patch" )
+
+src_compile() {
+ if use doc; then
+ sphinx-build docsrc html || die
+ fi
+}
+
+lua_src_test() {
+ busted --lua=${ELUA} || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ insinto "$(lua_get_lmod_dir)"
+ doins -r src/luacheck
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ newbin bin/luacheck.lua luacheck
+
+ use doc && local -a HTML_DOCS=( "html/." )
+ einstalldocs
+}
diff --git a/dev-lua/luacheck/metadata.xml b/dev-lua/luacheck/metadata.xml
index b17c5d22780c..55354930c5ca 100644
--- a/dev-lua/luacheck/metadata.xml
+++ b/dev-lua/luacheck/metadata.xml
@@ -15,10 +15,12 @@
</maintainer>
<longdescription lang="en">
A tool for linting and static analysis of Lua code.
-
- Luacheck supports checking Lua files using syntax of Lua 5.1, Lua 5.2, Lua 5.3 and LuaJIT. Luacheck itself is written in Lua and runs on all of mentioned Lua versions.
+ Luacheck supports checking Lua files using syntax of
+ Lua 5.1, Lua 5.2, Lua 5.3, Lua 5.4 and LuaJIT.
+ Luacheck itself is written in Lua and runs on all of mentioned Lua versions.
</longdescription>
<upstream>
+ <remote-id type="github">luarocks/luacheck</remote-id>
<remote-id type="github">mpeterv/luacheck</remote-id>
</upstream>
</pkgmetadata>