summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:34:51 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:51 +0100
commit20492f597bf23ae73a31febb01f8750b0a142b1d (patch)
tree95b8d4a25925548409c7fcd7b5340e255d0832a5 /dev-lua
parentdev-lua/luaossl: drop 20200709-r102 (diff)
downloadgentoo-20492f597bf23ae73a31febb01f8750b0a142b1d.tar.gz
gentoo-20492f597bf23ae73a31febb01f8750b0a142b1d.tar.bz2
gentoo-20492f597bf23ae73a31febb01f8750b0a142b1d.zip
dev-lua/luassert: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luassert/luassert-1.8.0-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-lua/luassert/luassert-1.8.0-r1.ebuild b/dev-lua/luassert/luassert-1.8.0-r1.ebuild
new file mode 100644
index 000000000000..bf708d9813d6
--- /dev/null
+++ b/dev-lua/luassert/luassert-1.8.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Assertion library for Lua"
+HOMEPAGE="http://olivinelabs.com/busted/"
+SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lua/say[${LUA_USEDEP}]
+ ${LUA_DEPS}
+"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-lua/busted[${LUA_USEDEP}]
+ dev-lua/lua_cliargs[${LUA_USEDEP}]
+ ${RDEPEND}
+ )
+"
+
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-1.8.0-disable-highlightcolor-test.patch" )
+
+lua_src_test() {
+ busted --lua=${ELUA} || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ insinto $(lua_get_lmod_dir)/luassert
+ doins -r src/.
+
+ einstalldocs
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}