summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-24 19:14:35 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-27 20:40:28 +0100
commit2a139d5c9d96f46b301b831900c455d914195912 (patch)
treeb3853ab6aa2b6bd0df8020ad990debd43de3f608 /dev-lua
parentdev-lua/luassert: drop old version (diff)
downloadgentoo-2a139d5c9d96f46b301b831900c455d914195912.tar.gz
gentoo-2a139d5c9d96f46b301b831900c455d914195912.tar.bz2
gentoo-2a139d5c9d96f46b301b831900c455d914195912.zip
dev-lua/luasystem: drop old version
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luasystem/Manifest1
-rw-r--r--dev-lua/luasystem/files/luasystem-0.2.0_p0-fix-makefile.patch33
-rw-r--r--dev-lua/luasystem/luasystem-0.2.0_p0.ebuild44
-rw-r--r--dev-lua/luasystem/luasystem-0.2.1_p0.ebuild56
4 files changed, 0 insertions, 134 deletions
diff --git a/dev-lua/luasystem/Manifest b/dev-lua/luasystem/Manifest
index eee4f695f364..c1feeb4a855b 100644
--- a/dev-lua/luasystem/Manifest
+++ b/dev-lua/luasystem/Manifest
@@ -1,2 +1 @@
-DIST luasystem-0.2.0_p0.tar.gz 8058 BLAKE2B fd29eaec7fe2f49e933932a436be75678400fc55a275e412379e05ab5b9cfe2036dfc9e61f960caa29d3c4ab1d439f9ede7ff3cbe14a61287270cc3707660636 SHA512 b8c7ba30470cbf100cc3f14df31729778cfb0aabebe4d27ce42c19581a2585f878d86a29a2f73fd1bef4e5861e2a604d3c396a73f131fa99ae14a17cba52c336
DIST luasystem-0.2.1_p0.tar.gz 8162 BLAKE2B ad8a6009823ad8202ff3884a3167d0779405c2a6be460b7ef2939622eb4d0fc8edbc6b04aba5dec9dd5e4e38f11ae0dcd582b9c348d5b516aa411858d55c6d71 SHA512 9dc323d4d1914cfa4f278a49ef22e58569d5cd7e369fa17fa6006cd47f9d90c6dfd4404067ea2436aa46a27cfbdf91e4aa26e20b89aeeefdf2aa7252c51fb32b
diff --git a/dev-lua/luasystem/files/luasystem-0.2.0_p0-fix-makefile.patch b/dev-lua/luasystem/files/luasystem-0.2.0_p0-fix-makefile.patch
deleted file mode 100644
index 803d2835c37f..000000000000
--- a/dev-lua/luasystem/files/luasystem-0.2.0_p0-fix-makefile.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff --git a/src/Makefile b/src/Makefile
-index 10fc31a..af5e4e4 100644
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -144,8 +144,8 @@ O_linux=o
- CC_linux=gcc
- DEF_linux=
- CFLAGS_linux= -I$(LUAINC) $(DEF) -Wall -Wshadow -Wextra \
-- -Wimplicit -O2 -ggdb3 -fpic -fvisibility=hidden
--LDFLAGS_linux=-lrt -O -shared -fpic -o
-+ -Wimplicit -fpic -fvisibility=hidden
-+LDFLAGS_linux=-lrt -shared -fpic -o
- LD_linux=gcc
-
- #------
-@@ -208,7 +208,7 @@ SOLIB=core.$(SO)
- #
- CC=$(CC_$(PLAT))
- DEF=$(DEF_$(PLAT))
--CFLAGS=$(MYCFLAGS) $(CFLAGS_$(PLAT))
-+CFLAGS=$(CFLAGS_$(PLAT)) $(MYCFLAGS)
- LDFLAGS=$(MYLDFLAGS) $(LDFLAGS_$(PLAT))
- LD=$(LD_$(PLAT))
- LUAINC= $(LUAINC_$(PLAT))
-@@ -248,7 +248,7 @@ none:
- all: $(SOLIB)
-
- $(SOLIB): $(OBJS)
-- $(LD) $(OBJS) $(LDFLAGS)$@
-+ $(LD) $(OBJS) $(LDFLAGS) $@
-
- install: all
- $(INSTALL_DIR) $(INSTALL_TOP_LDIR)
diff --git a/dev-lua/luasystem/luasystem-0.2.0_p0.ebuild b/dev-lua/luasystem/luasystem-0.2.0_p0.ebuild
deleted file mode 100644
index 6446cfc61d64..000000000000
--- a/dev-lua/luasystem/luasystem-0.2.0_p0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-# The below is the upstream version number. The -x suffix should be kept
-# in sync with the _px suffix in the ebuild version.
-MY_PV="0.2.0-0"
-
-DESCRIPTION="platform independent system calls for lua"
-HOMEPAGE="https://github.com/LuaDist2/luasystem"
-SRC_URI="https://github.com/LuaDist2/luasystem/archive/${MY_PV}.tar.gz ->
- ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm ppc ppc64 x86"
-IUSE=""
-
-COMMON_DEPEND=">=dev-lang/lua-5.1:0="
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig"
-RDEPEND="${COMMON_DEPEND}"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-fix-makefile.patch
-)
-
-src_compile() {
- emake CC="$(tc-getCC)" MYCFLAGS="${CFLAGS}" \
- LD="$(tc-getCC)" MYLDFLAGS="${LDFLAGS}"
-}
-
-src_install() {
- insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
- doins -r system
- exeinto "$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)"/system
- doexe src/core.so
-dodoc README.md
-}
diff --git a/dev-lua/luasystem/luasystem-0.2.1_p0.ebuild b/dev-lua/luasystem/luasystem-0.2.1_p0.ebuild
deleted file mode 100644
index 5b23c11d98c5..000000000000
--- a/dev-lua/luasystem/luasystem-0.2.1_p0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-# The below is the upstream version number. The -x suffix should be kept
-# in sync with the _px suffix in the ebuild version.
-MY_PV="0.2.1-0"
-
-DESCRIPTION="platform independent system calls for lua"
-HOMEPAGE="https://github.com/LuaDist2/luasystem"
-SRC_URI="https://github.com/LuaDist2/luasystem/archive/${MY_PV}.tar.gz ->
- ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 arm arm64 ppc ppc64 x86"
-IUSE="luajit test"
-
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- virtual/pkgconfig
- test? (
- ${RDEPEND}
- dev-lua/busted
- )"
-RDEPEND="
- !luajit? ( >=dev-lang/lua-5.1:0= )
- luajit? ( dev-lang/luajit:2 )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-fix-makefile.patch
-)
-
-src_test() {
- busted -o gtest || die
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" MYCFLAGS="${CFLAGS}" \
- LD="$(tc-getCC)" MYLDFLAGS="${LDFLAGS}"
-}
-
-src_install () {
- insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
- doins -r system
- exeinto "$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)"/system
- doexe src/core.so
- einstalldocs
-}