summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-02-28 15:46:57 -0500
committerMatt Turner <mattst88@gentoo.org>2024-02-29 11:47:44 -0500
commit2d2ab59b783760f8ac0dc867833accb75971fb9d (patch)
tree35ddbd0ed450e0e270f397e214c3ab30a2ac4f6c /dev-lua
parentdev-libs/libtermkey: Use PKG_PROG_PKG_CONFIG (diff)
downloadgentoo-2d2ab59b783760f8ac0dc867833accb75971fb9d.tar.gz
gentoo-2d2ab59b783760f8ac0dc867833accb75971fb9d.tar.bz2
gentoo-2d2ab59b783760f8ac0dc867833accb75971fb9d.zip
dev-lua/mpack: Export PKG_CONFIG for src_compile
The Makefile does this: > PKG_CONFIG ?= pkg-config so we need to export PKG_CONFIG to use the correct pkg-config binary when cross-compiling. Closes: https://github.com/gentoo/gentoo/pull/35572 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/mpack/mpack-1.0.12.ebuild1
1 files changed, 1 insertions, 0 deletions
diff --git a/dev-lua/mpack/mpack-1.0.12.ebuild b/dev-lua/mpack/mpack-1.0.12.ebuild
index e724b86a46b8..0d3dc279196c 100644
--- a/dev-lua/mpack/mpack-1.0.12.ebuild
+++ b/dev-lua/mpack/mpack-1.0.12.ebuild
@@ -58,6 +58,7 @@ lua_src_compile() {
}
src_compile() {
+ tc-export PKG_CONFIG
lua_foreach_impl lua_src_compile
}