summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-11-30 02:04:02 +0100
committerMarek Szuba <marecki@gentoo.org>2020-11-30 02:08:27 +0100
commit3ba91476bf7a524125c8fa249c7adb1acde70cc3 (patch)
tree3bbccde908376143614ac5a44812a666b7fd64bc /dev-lua
parentdev-lua/luarocks: remove dev-lua/busted{,-htest} version requirement (diff)
downloadgentoo-3ba91476bf7a524125c8fa249c7adb1acde70cc3.tar.gz
gentoo-3ba91476bf7a524125c8fa249c7adb1acde70cc3.tar.bz2
gentoo-3ba91476bf7a524125c8fa249c7adb1acde70cc3.zip
dev-lua/luarocks-3.4.0-r100: add a postinst message about Lua versions
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luarocks/luarocks-3.4.0-r100.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-lua/luarocks/luarocks-3.4.0-r100.ebuild b/dev-lua/luarocks/luarocks-3.4.0-r100.ebuild
index ac482071bc61..6dcf557087ad 100644
--- a/dev-lua/luarocks/luarocks-3.4.0-r100.ebuild
+++ b/dev-lua/luarocks/luarocks-3.4.0-r100.ebuild
@@ -59,3 +59,20 @@ src_install() {
{ find "${D}" -type f -exec sed -i -e "s:${D}::g" {} \;; } || die
}
+
+pkg_postinst() {
+ local lua_abi_ver
+ if use lua_single_target_luajit; then
+ lua_abi_ver="5.1"
+ else
+ lua_abi_ver=${ELUA#lua}
+ fi
+ elog
+ elog "To manage rocks for a Lua version other than the current ${CATEGORY}/${PN} default (${lua_abi_ver})"
+ elog "you can use the command-line option --lua-version, e.g."
+ elog
+ elog " luarocks --lua-version 5.3 install luasocket"
+ elog
+ elog "(use 5.1 for luajit). Note that the relevant Lua version must already be present in the system."
+ elog
+}