summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-24 18:55:37 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-27 20:40:12 +0100
commit5d87be44c242efb2fa1fd7fdf376889c209dffe7 (patch)
tree9ee41fac4c97693261f8492ad8433540f854338f /dev-lua
parentdev-lua/lanes: drop old version (diff)
downloadgentoo-5d87be44c242efb2fa1fd7fdf376889c209dffe7.tar.gz
gentoo-5d87be44c242efb2fa1fd7fdf376889c209dffe7.tar.bz2
gentoo-5d87be44c242efb2fa1fd7fdf376889c209dffe7.zip
dev-lua/lua-argparse: drop old version
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/lua-argparse/lua-argparse-0.6.0-r1.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-lua/lua-argparse/lua-argparse-0.6.0-r1.ebuild b/dev-lua/lua-argparse/lua-argparse-0.6.0-r1.ebuild
deleted file mode 100644
index f17a8188bc05..000000000000
--- a/dev-lua/lua-argparse/lua-argparse-0.6.0-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit toolchain-funcs
-
-DESCRIPTION="Command line argument parser for the Lua Programming Language"
-HOMEPAGE="https://github.com/mpeterv/argparse"
-SRC_URI="https://github.com/mpeterv/argparse/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
-IUSE="doc luajit test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-lang/lua-5.1:0=
- luajit? ( dev-lang/luajit:2 )"
-BDEPEND="
- virtual/pkgconfig
- doc? ( dev-python/sphinx )
- test? (
- ${RDEPEND}
- dev-lua/busted
- )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${PN//lua-/}-${PV}"
-
-src_compile() {
- if use doc; then
- sphinx-build docsrc html || die
- rm -rf "${S}"/html/{.doctrees,_sources} || die
- fi
-}
-
-src_test() {
- busted -o gtest --exclude-tags="unsafe" || die
-}
-
-src_install() {
- use doc && local -a HTML_DOCS=( html/. )
- local -a DOCS=( README.md CHANGELOG.md )
- einstalldocs
-
- local instdir
- instdir="$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD $(usex luajit 'luajit' 'lua'))"
-
- insinto "${instdir#${EPREFIX}}"
- doins src/argparse.lua
-}