summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-27 20:45:43 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-27 20:45:43 +0100
commit72da04974e882d6f13e4c4c87181915d0b5a3f8c (patch)
treec07c63177e334102c970875bf40a282d89fd746c /dev-lua
parentdev-lua/say: drop old version (diff)
downloadgentoo-72da04974e882d6f13e4c4c87181915d0b5a3f8c.tar.gz
gentoo-72da04974e882d6f13e4c4c87181915d0b5a3f8c.tar.bz2
gentoo-72da04974e882d6f13e4c4c87181915d0b5a3f8c.zip
dev-lua/luasec: drop live ebuild
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luasec/luasec-9999.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-lua/luasec/luasec-9999.ebuild b/dev-lua/luasec/luasec-9999.ebuild
deleted file mode 100644
index 0023fbd9de48..000000000000
--- a/dev-lua/luasec/luasec-9999.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib toolchain-funcs
-
-DESCRIPTION="Lua binding for OpenSSL library to provide TLS/SSL communication"
-HOMEPAGE="https://github.com/brunoos/luasec"
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/brunoos/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/brunoos/luasec/archive/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
- S=${WORKDIR}/${PN}-${P}
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="libressl"
-
-RDEPEND="
- >=dev-lang/lua-5.1:0[deprecated]
- dev-lua/luasocket
- !libressl? ( dev-libs/openssl:0= ) libressl? ( dev-libs/libressl:= )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- default
- sed -i -e "s/-O2//" src/Makefile || die
- lua src/options.lua -g /usr/include/openssl/ssl.h > src/options.h || die
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- LD="$(tc-getCC)" \
- linux
-}
-
-src_install() {
- emake \
- LUAPATH="${D}/$(pkg-config --variable INSTALL_LMOD lua)" \
- LUACPATH="${D}/$(pkg-config --variable INSTALL_CMOD lua)" \
- install
-}