summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-06-23 21:13:59 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-06-23 21:13:59 +0200
commit8085532be84cccefe4838adf35baea7cfdb4b4b1 (patch)
treebd7857d39119cd86a3530353ef76a5caec3f820b /dev-lua
parentdev-lua/lualdap: bump to version 1.3.0 (diff)
downloadgentoo-8085532be84cccefe4838adf35baea7cfdb4b4b1.tar.gz
gentoo-8085532be84cccefe4838adf35baea7cfdb4b4b1.tar.bz2
gentoo-8085532be84cccefe4838adf35baea7cfdb4b4b1.zip
dev-lua/lualdap: drop old version
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/lualdap/Manifest2
-rw-r--r--dev-lua/lualdap/lualdap-1.2.6.ebuild98
2 files changed, 0 insertions, 100 deletions
diff --git a/dev-lua/lualdap/Manifest b/dev-lua/lualdap/Manifest
index cef6aa86fb63..fee4147b5b72 100644
--- a/dev-lua/lualdap/Manifest
+++ b/dev-lua/lualdap/Manifest
@@ -1,3 +1 @@
-DIST lua-compat-5.3-0.10.tar.gz 53695 BLAKE2B e570aedb23b8ed7ca38c4316ffab25b93a0f9f6f0fae79af563ca8a81dd6453ac273e1f9e70674c484a2dec68749e7d53a1c1736a72616c210b8e38a31b3f191 SHA512 f7f39085f4f6b16095f41e635b4c5477b3dab5e42b5b65a9d522941a3807ea521d4a27a77293a3c9d0ecea78a1f6c2a2497394b2d220f4d7d65e23510563d46d
-DIST lualdap-1.2.6.tar.gz 92669 BLAKE2B 49b4c8e639ff109e32321fa5a6313dcb6e83b76d1e5220b59d7297cc19d106233a2d05ff8fc43162ad242d3134700a9abe8fe8f4bcbd90a3f8f0217217decfaa SHA512 e32010caa8efea5c23f2a595bd6a339267ecd08cf23e39389005bf8e499d6bad63771d0c7faf3ab5b8f670ba22bb15bf7ae691ed67920e86d8ed2c5649d7a079
DIST lualdap-1.3.0.tar.gz 81987 BLAKE2B cd25cada91a3c330fb72ee1106298442c64b1bcae4a57f48937efb4311f70b53c5a0e96587caab4b1950b16d9957bb8c25b2b9e0d3753089f06fbae64180ff04 SHA512 dea4282928c5138a327cd97d3d8049341fac17b5e853440f5b0a6e115e3400bac908f24827d48e36bfe81720c7d2bacdc50ae189953ecbcdfb27cb23b78d0de8
diff --git a/dev-lua/lualdap/lualdap-1.2.6.ebuild b/dev-lua/lualdap/lualdap-1.2.6.ebuild
deleted file mode 100644
index 448ea47d5f01..000000000000
--- a/dev-lua/lualdap/lualdap-1.2.6.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-MY_PN_LUACOMPAT="lua-compat-5.3"
-MY_PV_LUACOMPAT="0.10"
-MY_P_LUACOMPAT="${MY_PN_LUACOMPAT}-${MY_PV_LUACOMPAT}"
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="A lua binding for the OpenLDAP client libraries"
-HOMEPAGE="https://github.com/lualdap/lualdap"
-SRC_URI="
- https://github.com/lualdap/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/keplerproject/${MY_PN_LUACOMPAT}/archive/v${MY_PV_LUACOMPAT}.tar.gz -> ${MY_P_LUACOMPAT}.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ia64 ~sparc ~x86"
-IUSE="test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-RESTRICT="test"
-
-RDEPEND="
- net-nds/openldap
- ${LUA_DEPS}
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- test? ( ${RDEPEND} )
-"
-
-HTML_DOCS=( "docs/." )
-
-src_prepare() {
- default
-
- # Copy current lua-compat-5.3 files to support lua5-4
- cp ../${MY_P_LUACOMPAT}/c-api/* src || die
-
- lua_copy_sources
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "LBER_LIBDIR=/usr/$(get_libdir)"
- "LDAP_LIBDIR=/usr/$(get_libdir)"
- "LUA_INCDIR=$(lua_get_include_dir)"
- "LUA_LIBDIR=/usr/$(get_libdir)"
- )
-
- emake "${myemakeargs[@]}"
-
- popd
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_test() {
- pushd "${BUILD_DIR}" || die
- LUA_CPATH="./src/?.so" ${ELUA} tests/test.lua
- popd
-}
-
-src_install() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- pushd "${BUILD_DIR}" || die
-
- # Workaround, as 'make install' does not create this directory
- dodir "$(lua_get_cmod_dir)"
-
- local myemakeargs=(
- "DESTDIR=${ED}"
- "INST_LIBDIR=$(lua_get_cmod_dir)"
- )
-
- emake "${myemakeargs[@]}" install
-
- popd
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}