summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-05-09 23:00:14 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-05-09 23:01:25 +0200
commit8105702f9bf4efb098c5f5623c6360259ec1621b (patch)
tree08f28b1de28be83c7ddcb6241ea5b7633cd3f905 /dev-lua
parentdev-python/humanize: enable Python 3.10 (diff)
downloadgentoo-8105702f9bf4efb098c5f5623c6360259ec1621b.tar.gz
gentoo-8105702f9bf4efb098c5f5623c6360259ec1621b.tar.bz2
gentoo-8105702f9bf4efb098c5f5623c6360259ec1621b.zip
dev-lua/md5: new package
MD5 offers basic cryptographic facilities for Lua. Closes: https://bugs.gentoo.org/665706 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/md5/Manifest1
-rw-r--r--dev-lua/md5/md5-1.3.ebuild85
-rw-r--r--dev-lua/md5/metadata.xml17
3 files changed, 103 insertions, 0 deletions
diff --git a/dev-lua/md5/Manifest b/dev-lua/md5/Manifest
new file mode 100644
index 000000000000..6da3d677a38a
--- /dev/null
+++ b/dev-lua/md5/Manifest
@@ -0,0 +1 @@
+DIST md5-1.3.tar.gz 31377 BLAKE2B b6080c1ef71b5dd1e2d1831b055f31c6a45dd530a24436440a2188500f2fe0ad45730b23627eed7135b01102797a290af65b7550960add10346ac9f7ce906a9a SHA512 eda222b89432228a03c603237a787d55b6d0251f53ee3da11aaf0369ff26e3497ed8479a295b659e02b3fee85c636cd5f8cc9fd68367bf4ed2d3edcbbc373903
diff --git a/dev-lua/md5/md5-1.3.ebuild b/dev-lua/md5/md5-1.3.ebuild
new file mode 100644
index 000000000000..95caf85b7d2f
--- /dev/null
+++ b/dev-lua/md5/md5-1.3.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua
+
+DESCRIPTION="Offers basic cryptographic facilities for Lua"
+HOMEPAGE="https://github.com/keplerproject/md5"
+SRC_URI="https://github.com/keplerproject/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ lua_copy_sources
+}
+
+src_configure() {
+ # Provided 'configure' script is useless.
+ :;
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ "CC=$(tc-getCC)"
+ "CFLAGS=${CFLAGS} $(lua_get_CFLAGS) ${LDFLAGS}"
+ )
+
+ emake "${myemakeargs[@]}"
+
+ popd
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_test() {
+ pushd "${BUILD_DIR}/src" || die
+
+ # Workaround for tests.
+ ln -s core.so md5.so || die
+
+ "${ELUA}" ../tests/test.lua
+
+ popd
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ # Workaround, as 'Makefile' does not create this directory.
+ dodir "$(lua_get_cmod_dir)"
+
+ local myemakeargs=(
+ "LUA_DIR=${ED}/$(lua_get_lmod_dir)"
+ "LUA_LIBDIR=${ED}/$(lua_get_cmod_dir)"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ popd
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}
diff --git a/dev-lua/md5/metadata.xml b/dev-lua/md5/metadata.xml
new file mode 100644
index 000000000000..5907ba34a816
--- /dev/null
+++ b/dev-lua/md5/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <longdescription>
+ MD5 offers basic cryptographic facilities for Lua.
+ A hash (digest) function, a pair crypt/decrypt based on MD5 and CFB,
+ and a pair crypt/decrypt based on DES with 56-bit keys.
+ </longdescription>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">keplerproject/md5</remote-id>
+ </upstream>
+</pkgmetadata>