summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-06-03 23:46:59 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-06-03 23:47:15 +0200
commit83bbe4cb59d0553c5d1f4591610f42365d96645a (patch)
tree1742255352aacb0c762be80e911b6084b0a03028 /dev-lua
parentdev-libs/concurrencykit: bump to version 0.7.1 (diff)
downloadgentoo-83bbe4cb59d0553c5d1f4591610f42365d96645a.tar.gz
gentoo-83bbe4cb59d0553c5d1f4591610f42365d96645a.tar.bz2
gentoo-83bbe4cb59d0553c5d1f4591610f42365d96645a.zip
dev-lua/luarocks: drop old version
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luarocks/Manifest1
-rw-r--r--dev-lua/luarocks/luarocks-3.5.0.ebuild86
2 files changed, 0 insertions, 87 deletions
diff --git a/dev-lua/luarocks/Manifest b/dev-lua/luarocks/Manifest
index f566b7e9d8a5..4683f7a36437 100644
--- a/dev-lua/luarocks/Manifest
+++ b/dev-lua/luarocks/Manifest
@@ -1,2 +1 @@
-DIST luarocks-3.5.0.tar.gz 244798 BLAKE2B 24ceead8953ad6d9eefbf471fd49e0bd82256cc00c201395770919a680873544db67f062a4af93ddd390985b0b74db55e37a95516287dfc1e077a25b67c9f264 SHA512 fda01b7149839adf7c0e1c05d0f1793e79575c5d378d96ee1e197828e9b9b6e89a635f8a26a5b71db5b48465ef74b219fac18ecdbd59962cbf9da613b05dd42a
DIST luarocks-3.7.0.tar.gz 247576 BLAKE2B b1e119ec897bc8122441445dc215e628d2415dacba9b23c2b075f82a01e21e6e9a8eeab5a3345355d85c566ff9f85ab29194580674521d4d92725b01377ee940 SHA512 cc3c555c488da9f95a118eedb74cb9e2a38b572e172958843dabebce125524e58a13ac65e89a349deb8fef13b6de751074fc3adbb430ab55d4e4109288119153
diff --git a/dev-lua/luarocks/luarocks-3.5.0.ebuild b/dev-lua/luarocks/luarocks-3.5.0.ebuild
deleted file mode 100644
index c76f49a19d3f..000000000000
--- a/dev-lua/luarocks/luarocks-3.5.0.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua-single
-
-DESCRIPTION="A package manager for the Lua programming language"
-HOMEPAGE="https://luarocks.org"
-SRC_URI="https://luarocks.org/releases/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 x86"
-IUSE="test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-RESTRICT="test"
-
-RDEPEND="${LUA_DEPS}"
-
-DEPEND="
- net-misc/curl
- dev-libs/openssl:0
- ${RDEPEND}
-"
-
-BDEPEND="
- virtual/pkgconfig
- test? (
- $(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]')
- $(lua_gen_cond_dep 'dev-lua/busted-htest[${LUA_USEDEP}]')
- ${RDEPEND}
- )
-"
-
-src_prepare() {
- default
-
- # If 'dev-lang/lua' is a new, fresh installation, no 'LUA_LIBDIR' exists,
- # as no compiled modules are installed on a new, fresh installation,
- # so this check must be disabled, otherwise 'configure' will fail.
- sed -e '/LUA_LIBDIR is not a valid directory/d' -i configure || die
-}
-
-src_configure() {
- local myeconfargs=(
- "--prefix=${EPREFIX}/usr"
- "--rocks-tree=$(lua_get_lmod_dir)"
- "--with-lua-include=$(lua_get_include_dir)"
- "--with-lua-interpreter=${ELUA}"
- "--with-lua-lib=$(lua_get_cmod_dir)"
- )
-
- # Since the configure script is handcrafted,
- # and yells at unknown options, do not use 'econf'.
- ./configure "${myeconfargs[@]}" || die
-}
-
-src_test() {
- busted --lua=${ELUA} || die
-}
-
-src_install() {
- default
-
- { find "${D}" -type f -exec sed -i -e "s:${D}::g" {} \;; } || die
-}
-
-pkg_postinst() {
- local lua_abi_ver
- if use lua_single_target_luajit; then
- lua_abi_ver="5.1"
- else
- lua_abi_ver=${ELUA#lua}
- fi
- elog
- elog "To manage rocks for a Lua version other than the current ${CATEGORY}/${PN} default (${lua_abi_ver})"
- elog "you can use the command-line option --lua-version, e.g."
- elog
- elog " luarocks --lua-version 5.3 install luasocket"
- elog
- elog "(use 5.1 for luajit). Note that the relevant Lua version must already be present in the system."
- elog
-}