summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-24 18:59:52 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-27 20:40:16 +0100
commit840ce114fbb9f44f1dccb4de23060b0f087a2583 (patch)
tree92076dc59041ce123b63b757cf9087a55da295af /dev-lua
parentdev-lua/lua-openssl: drop old version (diff)
downloadgentoo-840ce114fbb9f44f1dccb4de23060b0f087a2583.tar.gz
gentoo-840ce114fbb9f44f1dccb4de23060b0f087a2583.tar.bz2
gentoo-840ce114fbb9f44f1dccb4de23060b0f087a2583.zip
dev-lua/lua-term: drop old version
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/lua-term/lua-term-0.7.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-lua/lua-term/lua-term-0.7.ebuild b/dev-lua/lua-term/lua-term-0.7.ebuild
deleted file mode 100644
index 854d2a4e4071..000000000000
--- a/dev-lua/lua-term/lua-term-0.7.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-# Yes, upstream used different version numbers.
-# The rockspec version number is 0.7, but the version associated with
-# the tarball is 0.07.
-MY_PV=0.07
-
-DESCRIPTION="Terminal functions for Lua"
-HOMEPAGE="https://github.com/hoelzro/lua-term"
-SRC_URI="https://github.com/hoelzro/lua-term/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
-IUSE=""
-
-BDEPEND="virtual/pkgconfig"
-RDEPEND=">=dev-lang/lua-5.1:0="
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-src_compile() {
- echo "$(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -fPIC -shared \
- -o core.so core.c"
- $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -fPIC -shared \
- -o core.so core.c || die
-}
-
-src_install() {
- exeinto "$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)"/term
- doexe core.so
- insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
- doins -r term
-}