summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-12-30 19:28:56 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-01-20 16:13:39 +0200
commitc6b3068f84b219767c87dd5a8d894dad561a55ea (patch)
treeb7b640bdb4ca81ce7b013e104b88b23621fe19fd /dev-lua
parentgames-util/deutex: Version bump to 5.2.2 (diff)
downloadgentoo-c6b3068f84b219767c87dd5a8d894dad561a55ea.tar.gz
gentoo-c6b3068f84b219767c87dd5a8d894dad561a55ea.tar.bz2
gentoo-c6b3068f84b219767c87dd5a8d894dad561a55ea.zip
dev-lua/luaposix: fix #762340
Disable ldoc automagic update. ldoc force update not needed as docs are in actual state. Closes: https://bugs.gentoo.org/762340 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luaposix/luaposix-35.0-r101.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/dev-lua/luaposix/luaposix-35.0-r101.ebuild b/dev-lua/luaposix/luaposix-35.0-r101.ebuild
new file mode 100644
index 000000000000..3b3b4f418c2b
--- /dev/null
+++ b/dev-lua/luaposix/luaposix-35.0-r101.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Bindings for POSIX APIs"
+HOMEPAGE="https://luaposix.github.io/luaposix/ https://github.com/luaposix/luaposix"
+SRC_URI="https://github.com/luaposix/luaposix/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+# Requires specl, which is not in the tree yet
+RESTRICT="test"
+
+DEPEND="${LUA_DEPS}"
+RDEPEND="${DEPEND}
+ lua_targets_lua5-1? ( dev-lua/lua-bit32[lua_targets_lua5-1(-)] )
+ lua_targets_luajit? ( dev-lua/lua-bit32[lua_targets_luajit(-)] )
+"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Temporary fix for respect LDFLAGS (#739050)
+ # Fixed in luke 0.2.1
+ sed -i -e "s:c_module,libdirs:c_module,'\$LDFLAGS',libdirs:g" \
+ build-aux/luke || die
+
+ lua_copy_sources
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ # LDOC=true means disable ldoc update documentation
+ ./build-aux/luke --verbose package="${PN}" version="${PV}" \
+ LDOC=true \
+ PREFIX="${ED}/usr" \
+ INST_LIBDIR="${ED}/$(lua_get_cmod_dir)" \
+ INST_LUADIR="${ED}/$(lua_get_lmod_dir)" \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)" || die
+
+ popd
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ ./build-aux/luke install \
+ LDOC=true \
+ PREFIX="${ED}/usr" \
+ INST_LIBDIR="${ED}/$(lua_get_cmod_dir)" \
+ INST_LUADIR="${ED}/$(lua_get_lmod_dir)" \
+ || die
+
+ popd
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+ dodoc {NEWS,README}.md
+ use doc && dodoc -r doc
+}