summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:18:27 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:37 +0100
commitcdebc814cd818def33f151dfef6f1249ba610c27 (patch)
tree176fc7c5b4cda722a2fd59a20ea9bda8bbb80dd0 /dev-lua
parentdev-lua/lua-bit32: update EAPI 7 -> 8 (diff)
downloadgentoo-cdebc814cd818def33f151dfef6f1249ba610c27.tar.gz
gentoo-cdebc814cd818def33f151dfef6f1249ba610c27.tar.bz2
gentoo-cdebc814cd818def33f151dfef6f1249ba610c27.zip
dev-lua/lua-bit32: drop 5.3.5.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/lua-bit32/lua-bit32-5.3.5.1.ebuild75
1 files changed, 0 insertions, 75 deletions
diff --git a/dev-lua/lua-bit32/lua-bit32-5.3.5.1.ebuild b/dev-lua/lua-bit32/lua-bit32-5.3.5.1.ebuild
deleted file mode 100644
index 01596fb23552..000000000000
--- a/dev-lua/lua-bit32/lua-bit32-5.3.5.1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-1 luajit )
-
-MY_PN="lua-compat-5.3"
-MY_PV="0.10"
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="Backported Lua bit manipulation library"
-HOMEPAGE="https://github.com/keplerproject/lua-compat-5.3"
-SRC_URI="https://github.com/keplerproject/${MY_PN}/archive/v${MY_PV}.tar.gz -> lua-compat53-${MY_PV}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${MY_PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-DEPEND="${LUA_DEPS}"
-RDEPEND="${DEPEND}"
-
-lua_src_compile() {
- local compiler=(
- "$(tc-getCC)"
- "${CFLAGS}"
- "-fPIC"
- "${LDFLAGS}"
- "-DLUA_COMPAT_BITLIB"
- "-Ic-api"
- "$(lua_get_CFLAGS)"
- "-c lbitlib.c"
- "-o lbitlib-${ELUA}.o"
- )
- einfo "${compiler[@]}"
- ${compiler[@]} || die
-
- local linker=(
- "$(tc-getCC)"
- "-shared"
- "${LDFLAGS}"
- "-o bit32-${ELUA}.so"
- "lbitlib-${ELUA}.o"
- )
- einfo "${linker[@]}"
- ${linker[@]} || die
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_test() {
- LUA_CPATH="./bit32-${ELUA}.so" "${ELUA}" "tests/test-bit32.lua" || die
-}
-
-src_test() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- exeinto "$(lua_get_cmod_dir)"
- newexe "bit32-${ELUA}.so" "bit32.so"
-}
-
-src_install() {
- default
-
- lua_foreach_impl lua_src_install
-}