summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:15:45 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:33 +0100
commitd42e04d4dffe97b03902d7feae875e58c715fe94 (patch)
treeef5835352699d47968cd4490f64d390b56990967 /dev-lua
parentdev-lua/dkjson: drop 2.5-r100 (diff)
downloadgentoo-d42e04d4dffe97b03902d7feae875e58c715fe94.tar.gz
gentoo-d42e04d4dffe97b03902d7feae875e58c715fe94.tar.bz2
gentoo-d42e04d4dffe97b03902d7feae875e58c715fe94.zip
dev-lua/inifile: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/inifile/inifile-1.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-lua/inifile/inifile-1.0-r1.ebuild b/dev-lua/inifile/inifile-1.0-r1.ebuild
new file mode 100644
index 000000000000..cadc6c0d76bb
--- /dev/null
+++ b/dev-lua/inifile/inifile-1.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+MY_PV="${PV/_p/-}"
+
+inherit lua
+
+DESCRIPTION="A simple and complete ini parser for Lua"
+HOMEPAGE="https://github.com/bartbes/inifile/"
+SRC_URI="https://github.com/bartbes/inifile/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="${LUA_DEPS}"
+BDEPEND="virtual/pkgconfig"
+
+lua_src_install() {
+ insinto $(lua_get_lmod_dir)
+ doins inifile.lua
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}