summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:35:53 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:52 +0100
commitf5cb9bffd2d74d561c59577009fb5a82b5827ec7 (patch)
treebb087a9a26909b99706196cb4727d59077f6f5a7 /dev-lua
parentdev-lua/luassert: drop 1.8.0-r101 (diff)
downloadgentoo-f5cb9bffd2d74d561c59577009fb5a82b5827ec7.tar.gz
gentoo-f5cb9bffd2d74d561c59577009fb5a82b5827ec7.tar.bz2
gentoo-f5cb9bffd2d74d561c59577009fb5a82b5827ec7.zip
dev-lua/luasystem: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luasystem/luasystem-0.2.1_p0-r1.ebuild91
1 files changed, 91 insertions, 0 deletions
diff --git a/dev-lua/luasystem/luasystem-0.2.1_p0-r1.ebuild b/dev-lua/luasystem/luasystem-0.2.1_p0-r1.ebuild
new file mode 100644
index 000000000000..35c3a8b2f37a
--- /dev/null
+++ b/dev-lua/luasystem/luasystem-0.2.1_p0-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+MY_PV="${PV/_p/-}"
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Platform independent system calls for Lua"
+HOMEPAGE="https://github.com/o-lim/luasystem/"
+SRC_URI="https://github.com/o-lim/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-lua/busted[${LUA_USEDEP}]
+ dev-lua/lua_cliargs[${LUA_USEDEP}]
+ ${RDEPEND}
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${P}-fix-makefile.patch )
+
+src_prepare() {
+ default
+
+ lua_copy_sources
+}
+
+lua_src_test() {
+ busted --lua=${ELUA} || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ "CC=$(tc-getCC)"
+ "LD=$(tc-getCC)"
+ "LUAINC_linux=$(lua_get_include_dir)"
+ "MYCFLAGS=${CFLAGS}"
+ "MYLDFLAGS=${LDFLAGS}"
+ )
+
+ emake "${myemakeargs[@]}" linux
+
+ popd
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_install () {
+ pushd "${BUILD_DIR}" || die
+
+ local emakeargs=(
+ "INSTALL_TOP_CDIR=${ED}/$(lua_get_cmod_dir)"
+ "INSTALL_TOP_LDIR=${ED}/$(lua_get_lmod_dir)"
+ "LUA_INC=${ED}/$(lua_get_include_dir)"
+ )
+
+ emake "${emakeargs[@]}" install
+
+ insinto $(lua_get_lmod_dir)/system
+ doins system/init.lua
+
+ popd
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}