summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-23 08:30:23 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-23 10:15:48 +0100
commitf6de0456845cdcc04b795344765aa3f089ad3bba (patch)
treeac538e5da6e94b1231097462f7e78688e93e7834 /dev-ml/astring/astring-0.8.3.ebuild
parentdev-ml/fmt: Initial import; ebuild by me. (diff)
downloadgentoo-f6de0456845cdcc04b795344765aa3f089ad3bba.tar.gz
gentoo-f6de0456845cdcc04b795344765aa3f089ad3bba.tar.bz2
gentoo-f6de0456845cdcc04b795344765aa3f089ad3bba.zip
dev-ml/astring: initial import; ebuild by me.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ml/astring/astring-0.8.3.ebuild')
-rw-r--r--dev-ml/astring/astring-0.8.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/astring/astring-0.8.3.ebuild b/dev-ml/astring/astring-0.8.3.ebuild
new file mode 100644
index 000000000000..be3d4ffadc4f
--- /dev/null
+++ b/dev-ml/astring/astring-0.8.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Alternative String module for OCaml"
+HOMEPAGE="http://erratique.ch/software/astring https://github.com/dbuenzli/astring"
+SRC_URI="http://erratique.ch/software/astring/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt]"
+DEPEND="${RDEPEND}
+ dev-ml/opam
+ dev-ml/topkg
+ dev-ml/ocamlbuild
+ dev-ml/findlib"
+
+src_compile() {
+ ocaml pkg/pkg.ml build || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md README.md
+}