summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-07-15 09:03:33 +0200
committerHans de Graaff <graaff@gentoo.org>2019-07-15 09:03:50 +0200
commit80e645f4fee50fcdd29d324a4867a4cb19a849e4 (patch)
tree7c261a0d2bd30fb3c32bb9b0c152fb717e74119c /dev-ml/async_ssl/async_ssl-0.9.1.ebuild
parentnet-analyzer/munin: remove obsolete ebuild (diff)
downloadgentoo-80e645f4fee50fcdd29d324a4867a4cb19a849e4.tar.gz
gentoo-80e645f4fee50fcdd29d324a4867a4cb19a849e4.tar.bz2
gentoo-80e645f4fee50fcdd29d324a4867a4cb19a849e4.zip
dev-ml/async_ssl: add 0.9.1
Fixes: https://bugs.gentoo.org/675502 Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-ml/async_ssl/async_ssl-0.9.1.ebuild')
-rw-r--r--dev-ml/async_ssl/async_ssl-0.9.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/async_ssl/async_ssl-0.9.1.ebuild b/dev-ml/async_ssl/async_ssl-0.9.1.ebuild
new file mode 100644
index 000000000000..aece7ea02729
--- /dev/null
+++ b/dev-ml/async_ssl/async_ssl-0.9.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="An Async-pipe-based interface with OpenSSL."
+HOMEPAGE="https://github.com/janestreet/async_ssl"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/async:=
+ dev-ml/base:=
+ dev-ml/configurator:=
+ dev-ml/core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_jane:=
+ dev-ml/stdio:=
+ dev-ml/ocaml-ctypes:=
+ dev-libs/openssl:0=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/opam
+ dev-ml/jbuilder
+"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}