summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/biniou
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/biniou')
-rw-r--r--dev-ml/biniou/Manifest1
-rw-r--r--dev-ml/biniou/biniou-1.0.9.ebuild32
-rw-r--r--dev-ml/biniou/metadata.xml5
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/biniou/Manifest b/dev-ml/biniou/Manifest
new file mode 100644
index 000000000000..31c44be21c1e
--- /dev/null
+++ b/dev-ml/biniou/Manifest
@@ -0,0 +1 @@
+DIST biniou-1.0.9.tar.gz 23963 SHA256 eb47c48f61b169e652629e7f2ee582dfd5965e640ee51bf28fab63b960864392 SHA512 8bc640da28ad8f95952b7a0965f8b40c6128264fb4cd5b517cba2e65b432803a01dc75e42d9d339376dbb962285c7e4ad8290f2536f58d092fe7269b731fb332 WHIRLPOOL aa7cf2486886cd26513028065d654f7c1b768e4950f568147758d5fa61cb6fcdc11a2f3da5ed6b60b8eadee14e3b8885e5197d52e01c8a61b284712cea7e9aa9
diff --git a/dev-ml/biniou/biniou-1.0.9.ebuild b/dev-ml/biniou/biniou-1.0.9.ebuild
new file mode 100644
index 000000000000..b5bb8f13dae8
--- /dev/null
+++ b/dev-ml/biniou/biniou-1.0.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="A binary data serialization format inspired by JSON for OCaml"
+HOMEPAGE="http://mjambon.com/biniou.html"
+SRC_URI="http://mjambon.com/releases/${PN}/${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt?]
+ dev-ml/easy-format:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake -j1 all
+ use ocamlopt && emake -j1 opt
+}
+
+src_install() {
+ use ocamlopt && dodir /usr/bin
+ findlib_src_install BINDIR="${ED}"/usr/bin
+ dodoc README.md Changes
+}
diff --git a/dev-ml/biniou/metadata.xml b/dev-ml/biniou/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/biniou/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>