summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-01-27 19:47:37 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-01-27 20:48:03 +0100
commit0629f0d020517794dd9c128c1630387333f1ff01 (patch)
tree8179f407c477401d527194140a46f96c958f558c /dev-ml/cairo2
parentdev-ml/base: add 0.15.1 (diff)
downloadgentoo-0629f0d020517794dd9c128c1630387333f1ff01.tar.gz
gentoo-0629f0d020517794dd9c128c1630387333f1ff01.tar.bz2
gentoo-0629f0d020517794dd9c128c1630387333f1ff01.zip
dev-ml/cairo2: add 0.6.4
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/cairo2')
-rw-r--r--dev-ml/cairo2/Manifest1
-rw-r--r--dev-ml/cairo2/cairo2-0.6.4.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/cairo2/Manifest b/dev-ml/cairo2/Manifest
index b35c69157d57..d382cb8fa78f 100644
--- a/dev-ml/cairo2/Manifest
+++ b/dev-ml/cairo2/Manifest
@@ -1,2 +1,3 @@
DIST cairo2-0.6.1.tbz 90006 BLAKE2B 78f1a998f821aad9b2a1d2deacffd9290920e6d351e0c66b6cc2a6f4f6140fef67c0dde9c1c317e743b5930e09d68d6c1830beb554d23ac9bcc95738a4091850 SHA512 d09274624854a45cf914ffbe984f1bcdd30db6283e7a0fd73aeec2a19226ff8f68d3f7139bbab72ca5698b58b840d6fd8a35570efc228391a7c5d031421f5c1f
DIST cairo2-0.6.2.tbz 90428 BLAKE2B a8c03e6ea8d4dcfc34a744f48b9a55a5e84b964602358f1c90aadcc5fdaed8eebecba2c851e71ef60066d42088d0baf9f4b90824541af93426e47f2539d6f41b SHA512 789b65428855c3b8fb71836ee6e607870c3140a6152fb01b8ba6e7d2e2f4842a62412061a5eff99023234d305587b605d0cbbacd29456c86a52e9df6466bd302
+DIST cairo2-0.6.4.tbz 90735 BLAKE2B d0e6617a1de99050553ebbb0ea9fa1567051923378b164f8ff073700cbda7275a7c5dc97ed74d9f891b18fe4a051b8da81450da4946364ea7c6e53ec10cc8ba0 SHA512 2fd755b32253a4c441146fb41d13bf7ad4ce3828bc479ece296fb58350e20c7349c22457ad99fa080407b5150ce337a753221043f18b7b641f4c5bc98e37e799
diff --git a/dev-ml/cairo2/cairo2-0.6.4.ebuild b/dev-ml/cairo2/cairo2-0.6.4.ebuild
new file mode 100644
index 000000000000..66f8aa4ef02f
--- /dev/null
+++ b/dev-ml/cairo2/cairo2-0.6.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Binding to Cairo, a 2D Vector Graphics Library"
+HOMEPAGE="https://github.com/Chris00/ocaml-cairo"
+SRC_URI="https://github.com/Chris00/ocaml-cairo/releases/download/${PV}/cairo2-${PV}.tbz"
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ppc64 x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ x11-libs/cairo:=[svg(+)]
+ dev-ml/dune-configurator:=
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+# >>> Test phase: dev-ml/cairo2-0.6.1
+# image_create alias tests/runtest (got signal SEGV)
+# (cd _build/default/tests && ./image_create.exe)
+# DESTROY bigarray 'data'
+# Done: 70/72 (jobs: 1) * ERROR: dev-ml/cairo2-0.6.1::x-portage failed (test phase):
+RESTRICT=test
+
+# Remove lablgtk2 dep https://github.com/Chris00/ocaml-cairo/issues/21
+# Fix compiler warnings, from: https://github.com/Chris00/ocaml-cairo/pull/22
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.1-ignore-gtk-and-pango.patch
+)