summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 05:43:06 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:54:44 +0100
commit6790d84353858d3c18373e7ab603af33cfccc7fb (patch)
treed68808145afb9de2419ffc95243af20c02218f53 /dev-ml/calendar
parentdev-ml/batteries: eutils-- (diff)
downloadgentoo-6790d84353858d3c18373e7ab603af33cfccc7fb.tar.gz
gentoo-6790d84353858d3c18373e7ab603af33cfccc7fb.tar.bz2
gentoo-6790d84353858d3c18373e7ab603af33cfccc7fb.zip
dev-ml/calendar: port to EAPI 7, eutils--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/calendar')
-rw-r--r--dev-ml/calendar/calendar-2.04.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-ml/calendar/calendar-2.04.ebuild b/dev-ml/calendar/calendar-2.04.ebuild
index 234cd57645b7..22c0e7d10f18 100644
--- a/dev-ml/calendar/calendar-2.04.ebuild
+++ b/dev-ml/calendar/calendar-2.04.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit findlib eutils
+inherit findlib
DESCRIPTION="An Ocaml library to handle dates and time"
HOMEPAGE="http://forge.ocamlcore.org/projects/calendar/"
@@ -29,5 +29,9 @@ src_test() {
src_install() {
findlib_src_install
dodoc README CHANGES
- use doc && dohtml -r doc
+
+ if use doc ; then
+ docinto html
+ dodoc -r doc
+ fi
}