summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-01-22 14:43:12 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-01-22 14:43:12 +0100
commit2b4dbdea0d25239a573a329efeeaaff8a88794f5 (patch)
tree43531945514865be26367841d74b06f3c07fc1d4 /dev-ml/camldbm
parentprofiles: last-rite net-misc/npapi-sdk (diff)
downloadgentoo-2b4dbdea0d25239a573a329efeeaaff8a88794f5.tar.gz
gentoo-2b4dbdea0d25239a573a329efeeaaff8a88794f5.tar.bz2
gentoo-2b4dbdea0d25239a573a329efeeaaff8a88794f5.zip
dev-ml/camldbm: do not call ranlib directly
Closes: https://bugs.gentoo.org/723142 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/camldbm')
-rw-r--r--dev-ml/camldbm/camldbm-1.0.ebuild12
-rw-r--r--dev-ml/camldbm/camldbm-1.2.ebuild12
2 files changed, 22 insertions, 2 deletions
diff --git a/dev-ml/camldbm/camldbm-1.0.ebuild b/dev-ml/camldbm/camldbm-1.0.ebuild
index 8f8d8b94854c..c025afbf93f0 100644
--- a/dev-ml/camldbm/camldbm-1.0.ebuild
+++ b/dev-ml/camldbm/camldbm-1.0.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="OCaml binding to the NDBM/GDBM Unix databases"
HOMEPAGE="http://forge.ocamlcore.org/projects/camldbm/"
SRC_URI="http://forge.ocamlcore.org/frs/download.php/728/${P}.tgz"
@@ -20,6 +22,14 @@ PATCHES=(
"${FILESDIR}/include_fix.patch"
)
+src_prepare() {
+ sed -i \
+ -e "s|ranlib|$(tc-getRANLIB)|g" \
+ Makefile \
+ || die
+ default
+}
+
src_install() {
dodir "$(ocamlc -where)/stublibs" # required and makefile does not create it
emake LIBDIR="${D}/$(ocamlc -where)" install
diff --git a/dev-ml/camldbm/camldbm-1.2.ebuild b/dev-ml/camldbm/camldbm-1.2.ebuild
index e8ed8d0f97ef..7fb74cd7c4c2 100644
--- a/dev-ml/camldbm/camldbm-1.2.ebuild
+++ b/dev-ml/camldbm/camldbm-1.2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="OCaml binding to the NDBM/GDBM Unix databases"
HOMEPAGE="https://github.com/ocaml/dbm"
SRC_URI="https://github.com/ocaml/dbm/archive/${P}.tar.gz"
@@ -21,6 +23,14 @@ QA_FLAGS_IGNORED=(
/usr/'lib.*'/ocaml/stublibs/dllcamldbm.so
)
+src_prepare() {
+ sed -i \
+ -e "s|ranlib|$(tc-getRANLIB)|g" \
+ Makefile \
+ || die
+ default
+}
+
src_install() {
dodir "$(ocamlc -where)/stublibs" # required and makefile does not create it
emake LIBDIR="${D}/$(ocamlc -where)" install