summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-01 20:37:21 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-02 20:29:06 +0100
commita5d5fe389f81e22c28fdc87811d1f0bcfaa30be0 (patch)
treeb06d85eb94176213f03f50ae3c418e4efaf2bf02 /dev-ml/camlidl
parentsci-libs/cdd+: add ~arm, bug #573324 (diff)
downloadgentoo-a5d5fe389f81e22c28fdc87811d1f0bcfaa30be0.tar.gz
gentoo-a5d5fe389f81e22c28fdc87811d1f0bcfaa30be0.tar.bz2
gentoo-a5d5fe389f81e22c28fdc87811d1f0bcfaa30be0.zip
dev-ml/camlidl: disable warnings so that it build with ocaml 4.03
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/camlidl')
-rw-r--r--dev-ml/camlidl/camlidl-1.05-r1.ebuild1
-rw-r--r--dev-ml/camlidl/files/nowarn.patch13
2 files changed, 14 insertions, 0 deletions
diff --git a/dev-ml/camlidl/camlidl-1.05-r1.ebuild b/dev-ml/camlidl/camlidl-1.05-r1.ebuild
index ea4debe95b7b..496779c37870 100644
--- a/dev-ml/camlidl/camlidl-1.05-r1.ebuild
+++ b/dev-ml/camlidl/camlidl-1.05-r1.ebuild
@@ -19,6 +19,7 @@ RDEPEND="${DEPEND}"
src_prepare() {
epatch "${FILESDIR}/tests.patch"
epatch "${FILESDIR}/includes.patch"
+ epatch "${FILESDIR}/nowarn.patch"
}
src_compile() {
diff --git a/dev-ml/camlidl/files/nowarn.patch b/dev-ml/camlidl/files/nowarn.patch
new file mode 100644
index 000000000000..8b457cf7ed1e
--- /dev/null
+++ b/dev-ml/camlidl/files/nowarn.patch
@@ -0,0 +1,13 @@
+Index: camlidl-1.05/compiler/Makefile
+===================================================================
+--- camlidl-1.05.orig/compiler/Makefile
++++ camlidl-1.05/compiler/Makefile
+@@ -29,7 +29,7 @@ PROG=camlidl$(EXE)
+ all: $(PROG)
+
+ $(PROG): $(OBJS)
+- $(OCAMLC) -o $(PROG) $(OBJS)
++ $(OCAMLC) -w -a -o $(PROG) $(OBJS)
+
+ clean::
+ rm -f $(PROG)