summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-12-28 16:40:32 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-12-28 16:40:32 +0300
commitc5a506d62eb8d841aa8fb29fa88da952f2fbe12b (patch)
tree6f8dff0db2bf76ccd6ee57c517ce7d4cb9f0a78d /dev-ml/camlp4/camlp4-4.08_p1.ebuild
parentdev-lang/ocaml: restore keywords (diff)
downloadgentoo-c5a506d62eb8d841aa8fb29fa88da952f2fbe12b.tar.gz
gentoo-c5a506d62eb8d841aa8fb29fa88da952f2fbe12b.tar.bz2
gentoo-c5a506d62eb8d841aa8fb29fa88da952f2fbe12b.zip
dev-ml/camlp4: Version bump (v4.08_p1)
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'dev-ml/camlp4/camlp4-4.08_p1.ebuild')
-rw-r--r--dev-ml/camlp4/camlp4-4.08_p1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/camlp4/camlp4-4.08_p1.ebuild b/dev-ml/camlp4/camlp4-4.08_p1.ebuild
new file mode 100644
index 000000000000..0c86d665428c
--- /dev/null
+++ b/dev-ml/camlp4/camlp4-4.08_p1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=${PV/_p/+}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="System for writing extensible parsers for programming languages"
+HOMEPAGE="https://github.com/ocaml/camlp4"
+SRC_URI="https://github.com/ocaml/camlp4/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-4.09.0:=[ocamlopt?]"
+RDEPEND="${DEPEND}
+ !<dev-lang/ocaml-4.02
+ !<dev-ml/findlib-1.5.5-r1"
+DEPEND="${DEPEND}
+ dev-ml/ocamlbuild"
+
+S=${WORKDIR}/${P/_p/-}
+PATCHES=( "${FILESDIR}/reload.patch" "${FILESDIR}/oc409.patch" )
+
+src_configure() {
+ ./configure \
+ --bindir="${EPREFIX}/usr/bin" \
+ --libdir="$(ocamlc -where)" \
+ --pkgdir="$(ocamlc -where)" \
+ || die
+}
+
+src_compile() {
+ emake byte
+ use ocamlopt && emake native
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-META
+ dodoc CHANGES.md README.md
+}