summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-11-10 01:03:59 +0000
committerSam James <sam@gentoo.org>2020-11-10 01:03:59 +0000
commita4c213ab1b5420acfb0adce3b36b7f02a72f003d (patch)
tree476e8d3ee310d7b75ac5fa2c158175401bd586f0 /dev-ml/camlp5/camlp5-7.11-r1.ebuild
parentapp-emulation/libvirt: 6.8.0/6.9.0 fix libvirt-lxc dbus connection (diff)
downloadgentoo-a4c213ab1b5420acfb0adce3b36b7f02a72f003d.tar.gz
gentoo-a4c213ab1b5420acfb0adce3b36b7f02a72f003d.tar.bz2
gentoo-a4c213ab1b5420acfb0adce3b36b7f02a72f003d.zip
dev-ml/camlp5: mark 7.11 incompat. w/ newer ocaml
Closes: https://bugs.gentoo.org/753713 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/camlp5/camlp5-7.11-r1.ebuild')
-rw-r--r--dev-ml/camlp5/camlp5-7.11-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-ml/camlp5/camlp5-7.11-r1.ebuild b/dev-ml/camlp5/camlp5-7.11-r1.ebuild
new file mode 100644
index 000000000000..5f91a735d0e7
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-7.11-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="https://camlp5.github.io/"
+SRC_URI="https://github.com/camlp5/camlp5/archive/rel$(ver_rs 1- '').tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-rel$(ver_rs 1- '')"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha amd64 ppc x86"
+IUSE="doc +ocamlopt"
+
+DEPEND="<dev-lang/ocaml-4.11.0:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+QA_FLAGS_IGNORED=(
+ /usr/bin/camlp5o.opt
+ /usr/bin/camlp5r.opt
+)
+
+DOCS="CHANGES DEVEL ICHANGES README.md UPGRADING MODE"
+
+src_configure() {
+ ./configure \
+ --strict \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+}
+
+src_compile() {
+ emake out
+ if use ocamlopt; then
+ emake opt
+ emake opt.opt
+ fi
+}
+
+src_install() {
+ use doc && HTML_DOCS="doc/*"
+
+ default
+
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META
+}