summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-21 00:19:58 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-21 01:47:54 -0600
commitce776ee40c63c35a72fc1db8eb07357aa19c078a (patch)
tree16996bd0b2870fdce1e26e1a5b7ab20b6ccafb99 /dev-ml/camlpdf
parentdev-python/idna-ssl: version bump to 1.1.0 (diff)
downloadgentoo-ce776ee40c63c35a72fc1db8eb07357aa19c078a.tar.gz
gentoo-ce776ee40c63c35a72fc1db8eb07357aa19c078a.tar.bz2
gentoo-ce776ee40c63c35a72fc1db8eb07357aa19c078a.zip
dev-ml/camlpdf: version bump to 2.2.1
Force ocamlopt to be enabled. Closes: https://bugs.gentoo.org/535824 Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-ml/camlpdf')
-rw-r--r--dev-ml/camlpdf/Manifest1
-rw-r--r--dev-ml/camlpdf/camlpdf-2.2.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/camlpdf/Manifest b/dev-ml/camlpdf/Manifest
index 726230c684a6..2980c627bd18 100644
--- a/dev-ml/camlpdf/Manifest
+++ b/dev-ml/camlpdf/Manifest
@@ -1 +1,2 @@
DIST camlpdf-2.1.1.tar.gz 563633 BLAKE2B 3ff7ec46bbac70eabe6695911e834a5f2122136fecba661ff708c86dfb8d928694d67054504028670c3138c600f7f770b540d87c4e1a0ed1e04c71e083afdc23 SHA512 db6f9f61c43113e1f4d8741d88766bacc489a45b8e7164e4619f8bb88c527bc7cbeebdaaa673a77ab16c60dc3c90d21a69844e9fed92c222fc8fe0424f328cf2
+DIST camlpdf-2.2.1.tar.gz 570782 BLAKE2B 218dc3f0de67eebd983a849769372daa5630b1c5b4f488f4eeb1c73defc8da76ce65c73e43dc6fed5474f78aa01331a93e83ae6289aa099d71e30cd6c13f0777 SHA512 7539294434479b529edb7b46017f324b98bc0b83d25c1254a52ab1b67f8e3e04c2b8709ba22c6a0ac5e4444c65ef37e4645a495ea3ee011d3e95cd3021d559c2
diff --git a/dev-ml/camlpdf/camlpdf-2.2.1.ebuild b/dev-ml/camlpdf/camlpdf-2.2.1.ebuild
new file mode 100644
index 000000000000..f6709f295c68
--- /dev/null
+++ b/dev-ml/camlpdf/camlpdf-2.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="OCaml library for reading, writing, and modifying PDF files"
+HOMEPAGE="https://github.com/johnwhitington/camlpdf/"
+SRC_URI="https://github.com/johnwhitington/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# technically LGPL-2.1+ with linking exception
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt]"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ # parallel make bugs
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+ dodoc Changes README.md
+
+ if use doc ; then
+ dodoc introduction_to_camlpdf.pdf
+ dodoc -r doc/camlpdf/html
+ fi
+
+ use examples && dodoc -r examples
+}