summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-05 14:12:34 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-05 14:12:39 +0200
commit48d6b8383c1261fb6c1b3d15fbe311eb4b14f865 (patch)
treec2f7c2b954111f1b9853765774ae16440d18c2cd /dev-ml/camlzip/camlzip-1.06.ebuild
parentapp-editors/joe: Some QA fixes suggested by Soap__ (diff)
downloadgentoo-48d6b8383c1261fb6c1b3d15fbe311eb4b14f865.tar.gz
gentoo-48d6b8383c1261fb6c1b3d15fbe311eb4b14f865.tar.bz2
gentoo-48d6b8383c1261fb6c1b3d15fbe311eb4b14f865.zip
dev-ml/camlzip: bump to 1.06
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ml/camlzip/camlzip-1.06.ebuild')
-rw-r--r--dev-ml/camlzip/camlzip-1.06.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/camlzip/camlzip-1.06.ebuild b/dev-ml/camlzip/camlzip-1.06.ebuild
new file mode 100644
index 000000000000..750167f12ac3
--- /dev/null
+++ b/dev-ml/camlzip/camlzip-1.06.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit findlib eutils
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
+HOMEPAGE="http://forge.ocamlcore.org/projects/camlzip/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1616/${P}.tar.gz"
+
+SLOT="1/${PV}"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND=">=dev-lang/ocaml-4.02:=[ocamlopt?]
+ >=sys-libs/zlib-1.1.3"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake all
+ if use ocamlopt; then
+ emake allopt
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ emake DESTDIR="${D}" install-findlib
+
+ dodoc README Changes
+}