summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-27 08:45:03 +0000
committerSam James <sam@gentoo.org>2021-01-27 08:45:47 +0000
commitd5e7699f5244fabbbcffcb4ae0985b465a404196 (patch)
tree47b1f9afdc212472026f17f0afaac2ca516688ac /dev-ml/core/core-0.14.0-r3.ebuild
parentnet-analyzer/zabbix: bump to 5.2.4 (diff)
downloadgentoo-d5e7699f5244fabbbcffcb4ae0985b465a404196.tar.gz
gentoo-d5e7699f5244fabbbcffcb4ae0985b465a404196.tar.bz2
gentoo-d5e7699f5244fabbbcffcb4ae0985b465a404196.zip
dev-ml/core: fix dependencies
* Drop dev-ml/ppx_assert * Drop dev-ml/ppx_driver * Drop dev-ml/ocaml-migrate-parsetree * Add dev-ml/timezone Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/core/core-0.14.0-r3.ebuild')
-rw-r--r--dev-ml/core/core-0.14.0-r3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/core/core-0.14.0-r3.ebuild b/dev-ml/core/core-0.14.0-r3.ebuild
new file mode 100644
index 000000000000..a5e510ea3268
--- /dev/null
+++ b/dev-ml/core/core-0.14.0-r3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Jane Street's alternative to the standard library"
+HOMEPAGE="https://github.com/janestreet/core"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="ocamlopt"
+
+# TODO: Wants quickcheck_deprecated?
+RESTRICT="test"
+
+RDEPEND="
+ dev-ml/base:=
+ dev-ml/core_kernel:=
+ dev-ml/jst-config:=
+ dev-ml/ppx_jane:=
+ dev-ml/sexplib:=
+ dev-ml/spawn:=
+ dev-ml/stdio:=
+ dev-ml/timezone:=
+"
+DEPEND="${RDEPEND}"