summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-15 11:46:52 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-15 11:49:15 +0200
commit053c3730bc66ddac70d3d3e3a21f8eb4a4312f74 (patch)
tree05a08cdac28e9e396f0f23b776c88598713b4104 /dev-ml/core/core-0.9.1-r1.ebuild
parentdev-util/debhelper: Old. (diff)
downloadgentoo-053c3730bc66ddac70d3d3e3a21f8eb4a4312f74.tar.gz
gentoo-053c3730bc66ddac70d3d3e3a21f8eb4a4312f74.tar.bz2
gentoo-053c3730bc66ddac70d3d3e3a21f8eb4a4312f74.zip
dev-ml/core: convert to opam.eclass and add fix for glibc 2.25
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-ml/core/core-0.9.1-r1.ebuild')
-rw-r--r--dev-ml/core/core-0.9.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/core/core-0.9.1-r1.ebuild b/dev-ml/core/core-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..45cc74eb4553
--- /dev/null
+++ b/dev-ml/core/core-0.9.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit opam
+
+DESCRIPTION="Jane Street's alternative to the standard library"
+HOMEPAGE="https://github.com/janestreet/core"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-ml/base:=
+ dev-ml/configurator:=
+ dev-ml/core_kernel:=
+ dev-ml/ppx_assert:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_jane:=
+ dev-ml/sexplib:=
+ dev-ml/spawn:=
+ dev-ml/stdio:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+DEPEND="${RDEPEND} dev-ml/jbuilder"
+PATCHES=( "${FILESDIR}/glibc225.patch" )