summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-02-29 19:23:37 -0500
committerSam James <sam@gentoo.org>2024-03-01 00:27:48 +0000
commit14f61484f67562f74ae0f03fe712b5e709178359 (patch)
tree4a3dcaaa506dc9d35e6c5f4fb7def19381b1587c /dev-ml/cryptokit/cryptokit-1.16.1-r1.ebuild
parentapp-admin/keepass: add 2.56 (diff)
downloadgentoo-14f61484f67562f74ae0f03fe712b5e709178359.tar.gz
gentoo-14f61484f67562f74ae0f03fe712b5e709178359.tar.bz2
gentoo-14f61484f67562f74ae0f03fe712b5e709178359.zip
dev-ml/cryptokit: mark "mpir" use dependency as disabled-if-missing
Support for mpir was removed from zarith, which means this is guaranteed to be disabled. That's what we want here anyway. Just indicate this with a use-dependency default. Fixes: a8c2b35f50a01d401be9c29abe6d720804ebbe44 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/cryptokit/cryptokit-1.16.1-r1.ebuild')
-rw-r--r--dev-ml/cryptokit/cryptokit-1.16.1-r1.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-ml/cryptokit/cryptokit-1.16.1-r1.ebuild b/dev-ml/cryptokit/cryptokit-1.16.1-r1.ebuild
deleted file mode 100644
index b2c57abf4cca..000000000000
--- a/dev-ml/cryptokit/cryptokit-1.16.1-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit dune
-
-MY_PV="$(ver_rs 1- '')"
-DESCRIPTION="Cryptographic primitives library for Objective Caml"
-HOMEPAGE="https://github.com/xavierleroy/cryptokit"
-SRC_URI="https://github.com/xavierleroy/cryptokit/archive/release${MY_PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-release${MY_PV}"
-
-LICENSE="LGPL-2"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc x86"
-IUSE="cpu_flags_x86_aes +ocamlopt test zlib"
-REQUIRED_USE="test? ( ocamlopt )"
-RESTRICT="!test? ( test )"
-
-# We can't use mpir on zarith
-# (until it gains mpz_powm_sec?)
-# bug #750740
-DEPEND="
- dev-ml/dune-configurator
- dev-ml/zarith:=[-mpir]
- zlib? ( >=sys-libs/zlib-1.1 )
-"
-RDEPEND="${DEPEND}"
-
-DOCS=( "Changes" "README.txt" "AUTHORS.txt" )
-
-src_configure() {
- # Don't build in src_configure
- sed -i -e 's:exit (Sys.command "dune build @configure --release")::' configure || die
-
- # It's not autotools (or even close), it's a Dune wrapper.
- ./configure \
- $(use_enable cpu_flags_x86_aes hardwaresupport) \
- $(use_enable zlib) \
- || die
-}
-
-pkg_postinst() {
- elog ""
- elog "This library uses the /dev/random device to generate "
- elog "random data and RSA keys. The device should either be"
- elog "built into the kernel or provided as a module. An"
- elog "alternative is to use the Entropy Gathering Daemon"
- elog "(http://egd.sourceforge.net). Please note that the"
- elog "remainder of the library will still work even in the"
- elog "absence of a one of these sources of randomness."
- elog ""
-}
-
-src_test() {
- echo ""
- einfo "You must have either /dev/random or the Entropy Gathering"
- einfo "Daemon (EGD) for this test to succeed!"
- echo ""
-
- dune_src_test
-}