summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-22 14:44:07 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-22 15:01:44 +0200
commit9cf6e315af74acd848a0b9ce6dbd955378ebf056 (patch)
tree5ea48c0d464aa8e820f4a3c08571b904b56676f9 /dev-ml/dose3
parentdev-ml/dose3: bump to 4.3 (diff)
downloadgentoo-9cf6e315af74acd848a0b9ce6dbd955378ebf056.tar.gz
gentoo-9cf6e315af74acd848a0b9ce6dbd955378ebf056.tar.bz2
gentoo-9cf6e315af74acd848a0b9ce6dbd955378ebf056.zip
dev-ml/dose3: fix build with ocamlgraph 1.8.7
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ml/dose3')
-rw-r--r--dev-ml/dose3/dose3-4.3.ebuild1
-rw-r--r--dev-ml/dose3/files/ocamlgraph.patch13
2 files changed, 14 insertions, 0 deletions
diff --git a/dev-ml/dose3/dose3-4.3.ebuild b/dev-ml/dose3/dose3-4.3.ebuild
index 681c3b5d8124..4b279d4fcb3b 100644
--- a/dev-ml/dose3/dose3-4.3.ebuild
+++ b/dev-ml/dose3/dose3-4.3.ebuild
@@ -41,6 +41,7 @@ RESTRICT="test"
S="${WORKDIR}/${MY_P}"
src_prepare() {
+ epatch "${FILESDIR}/ocamlgraph.patch"
sed -e 's/INSTALLOPTS=-s/INSTALLOPTS=/' -i Makefile.config.in || die
}
diff --git a/dev-ml/dose3/files/ocamlgraph.patch b/dev-ml/dose3/files/ocamlgraph.patch
new file mode 100644
index 000000000000..6f8edee5fbcc
--- /dev/null
+++ b/dev-ml/dose3/files/ocamlgraph.patch
@@ -0,0 +1,13 @@
+Index: dose3-4.3/algo/dominators.ml
+===================================================================
+--- dose3-4.3.orig/algo/dominators.ml
++++ dose3-4.3/algo/dominators.ml
+@@ -101,7 +101,7 @@ let dominators_tarjan graph =
+ ) graph;
+
+ Util.Timer.start tjntimer;
+-#if OCAMLGRAPHVERSION <= 186
++#if OCAMLGRAPHVERSION >= 186
+ let module Dom = Dominator.Make_graph(G) in
+ #else
+ let module Dom = Dominator.Make(G) in