summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-01-29 20:26:30 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-01-29 20:31:17 +0100
commit8c9dba3020887288cbf78079f6b25ac449dfc7fe (patch)
tree94ec7f5e9fc8063798331b633a6d75814dbad748 /dev-ml/dune-build-info/dune-build-info-2.9.3.ebuild
parentdev-util/libabigail: fix build on musl (diff)
downloadgentoo-8c9dba3020887288cbf78079f6b25ac449dfc7fe.tar.gz
gentoo-8c9dba3020887288cbf78079f6b25ac449dfc7fe.tar.bz2
gentoo-8c9dba3020887288cbf78079f6b25ac449dfc7fe.zip
dev-ml/dune-build-info: 2.9.3 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/dune-build-info/dune-build-info-2.9.3.ebuild')
-rw-r--r--dev-ml/dune-build-info/dune-build-info-2.9.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/dune-build-info/dune-build-info-2.9.3.ebuild b/dev-ml/dune-build-info/dune-build-info-2.9.3.ebuild
new file mode 100644
index 000000000000..664ba4dfaa9c
--- /dev/null
+++ b/dev-ml/dune-build-info/dune-build-info-2.9.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune multiprocessing
+
+DESCRIPTION="Embed locations informations inside executable and libraries"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> dune-${PV}.tar.gz"
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune build -p ${PN} @install --display short -j $(makeopts_jobs) || die
+}