summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-11-20 11:07:18 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-11-20 11:07:18 +0100
commit5ba6890b9d5cf2745b4bf0bd2403c0ff150157c9 (patch)
tree00d50f4be5b9a94a0f9d30f30628e7b76e158bbe /dev-ml/dune-private-libs/dune-private-libs-3.0.3-r1.ebuild
parentdev-ml/stdune: adj deps (diff)
downloadgentoo-5ba6890b9d5cf2745b4bf0bd2403c0ff150157c9.tar.gz
gentoo-5ba6890b9d5cf2745b4bf0bd2403c0ff150157c9.tar.bz2
gentoo-5ba6890b9d5cf2745b4bf0bd2403c0ff150157c9.zip
dev-ml/dune-private-libs: adj deps
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/dune-private-libs/dune-private-libs-3.0.3-r1.ebuild')
-rw-r--r--dev-ml/dune-private-libs/dune-private-libs-3.0.3-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/dune-private-libs/dune-private-libs-3.0.3-r1.ebuild b/dev-ml/dune-private-libs/dune-private-libs-3.0.3-r1.ebuild
new file mode 100644
index 000000000000..5000ebb7def9
--- /dev/null
+++ b/dev-ml/dune-private-libs/dune-private-libs-3.0.3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune multiprocessing
+
+DESCRIPTION="Private libraries of Dune"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> dune-${PV}.tar.gz"
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+BDEPEND=">=dev-ml/dune-3"
+DEPEND="
+ >=dev-ml/csexp-1.5:=[ocamlopt?]
+ dev-ml/pp:=[ocamlopt?]
+ ~dev-ml/dyn-${PV}:=[ocamlopt?]
+ ~dev-ml/stdune-${PV}:=[ocamlopt?]
+ >=dev-lang/ocaml-4.08
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ ./configure \
+ --libdir="$(ocamlc -where)" \
+ --mandir="/usr/share/man" \
+ || die
+}
+
+src_compile() {
+ dune build -p "${PN}" @install -j $(makeopts_jobs) --profile release || die
+}