summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-12-16 13:31:37 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-12-16 13:32:05 +0100
commit9684dd98f4e4800c6d260084585cb765ef55b550 (patch)
tree8f0aa393b35c4049e9d8a523569012d6a3903394 /dev-ml/dune
parentmedia-libs/tiff-compat: Add a blocker on matching tiff versions (diff)
downloadgentoo-9684dd98f4e4800c6d260084585cb765ef55b550.tar.gz
gentoo-9684dd98f4e4800c6d260084585cb765ef55b550.tar.bz2
gentoo-9684dd98f4e4800c6d260084585cb765ef55b550.zip
dev-ml/dune: add 3.5.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/dune')
-rw-r--r--dev-ml/dune/Manifest1
-rw-r--r--dev-ml/dune/dune-3.5.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-ml/dune/Manifest b/dev-ml/dune/Manifest
index c8df7791ba79..1740fdd7642a 100644
--- a/dev-ml/dune/Manifest
+++ b/dev-ml/dune/Manifest
@@ -4,3 +4,4 @@ DIST dune-2.9.3.tar.gz 1387667 BLAKE2B 3db54c780b9d13f40c774f53c3fe471dba4a640e7
DIST dune-3.0.3.tar.gz 1725788 BLAKE2B 2de93c085f642c8381642a08b18bc21ad48097f32397b3eddab9725deb267b089849b649705e1b72bb1b5b37f7531fd9e0cfb134174f0cb3a8ee2595c7dcf8ce SHA512 839e942bcf8189763d0d9b01614333bb2f036bce68c82959e51d2e9145b57067cb862b66781912391c1a0f531b8dddf2ffeafcee71c626169a437fe40feba155
DIST dune-3.1.1.tar.gz 1738713 BLAKE2B 29e2034a551f9fbc57aeb1056f934ee5b69d38743178743f9b4f9cfa9e43a805ef7eb904a25f5ff6b4944d47032ccb1c8fb420b48f85dd14bdd14350cc53f77c SHA512 3a99a66c449f9e6bf12bb21d2d6871f4d34677a8c0c63e47b3687e2af3d8c62ab4ab62809c5885f2d61a1ed93a88f90cadc0f8db0c95442410c0a964892bd3b8
DIST dune-3.2.0.tar.gz 1754664 BLAKE2B 97ba420a5bf9dd8e14ba74c0e91b6679924fd9ee7b8d9a9a2d4b282166d9172582a37adf408fd037972dab7525cd240c24729b6692f403c32029b2994044bd40 SHA512 a90ac689d97acab956fd96f16f7c6cfdc95d01785fc14f0d3c8ab39231ff78e8941d2db2fa8cbfaa39bbed8f865e11b628aacae1b22df49512a57d0263c0dca4
+DIST dune-3.5.0.tar.gz 1801260 BLAKE2B 684c6540c3f5e9356e12f1b483b1adbf9f4a44bb24fdd8b79bc5d48efab05b479cef0c9449adb84e3e30be81f07913460073928d5e91647096fc02608f8e9709 SHA512 f1a94d867e1b82502aed3f7ae16adb48bd1f773c0045c3313303f29b70ec99bed4264d420c85fe7c4be2343ac970586d77705f6083049c6bec860b543fbd3c3c
diff --git a/dev-ml/dune/dune-3.5.0.ebuild b/dev-ml/dune/dune-3.5.0.ebuild
new file mode 100644
index 000000000000..b406b7f73f41
--- /dev/null
+++ b/dev-ml/dune/dune-3.5.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multiprocessing elisp-common
+
+DESCRIPTION="A composable build system for OCaml"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="emacs"
+RESTRICT="strip test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08:=
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
+DEPEND="${RDEPEND}"
+
+QA_FLAGS_IGNORED="usr/bin/dune"
+
+BYTECOMPFLAGS="-L ${S}/editor-integration/emacs"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+
+ # This allows `dune --version` to output the correct version
+ # instead of "n/a"
+ sed -i "/^(name dune)/a (version ${PV})" dune-project || die
+}
+
+src_configure() {
+ ./configure \
+ --libdir="$(ocamlc -where)" \
+ --mandir=/usr/share/man \
+ --docdir=/usr/doc \
+ --etcdir=/etc \
+ --datadir=/usr/share \
+ --sbindir=/usr/sbin \
+ --bindir=/usr/bin \
+ || die
+}
+
+src_compile() {
+ ocaml bootstrap.ml -j $(makeopts_jobs) || die
+ ./dune.exe build -p "${PN}" --profile dune-bootstrap -j $(makeopts_jobs) \
+ --display short || die
+
+ use emacs && elisp-compile editor-integration/emacs/*.el
+}
+
+src_install() {
+ default
+
+ dodir /usr/share/doc
+ mv "${ED}"/usr/doc/dune "${ED}"/usr/share/doc/${PF} || die
+ rmdir "${ED}"/usr/doc || die
+
+ if use emacs ; then
+ elisp-install ${PN} editor-integration/emacs/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}