summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-11-22 20:30:02 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-11-22 20:30:02 +0100
commit640ca3589e9dd33bb182191e79906cb28aad87b2 (patch)
tree4cdc537e907792eab6956ea093d38f36607a6a3c /dev-ml/dyn
parentdev-ml/ordering: add 3.2.0 (diff)
downloadgentoo-640ca3589e9dd33bb182191e79906cb28aad87b2.tar.gz
gentoo-640ca3589e9dd33bb182191e79906cb28aad87b2.tar.bz2
gentoo-640ca3589e9dd33bb182191e79906cb28aad87b2.zip
dev-ml/dyn: add 3.2.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/dyn')
-rw-r--r--dev-ml/dyn/Manifest1
-rw-r--r--dev-ml/dyn/dyn-3.2.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/dyn/Manifest b/dev-ml/dyn/Manifest
index 773da28d4eed..38b3467e5fb8 100644
--- a/dev-ml/dyn/Manifest
+++ b/dev-ml/dyn/Manifest
@@ -1 +1,2 @@
DIST dune-3.0.3.tar.gz 1725788 BLAKE2B 2de93c085f642c8381642a08b18bc21ad48097f32397b3eddab9725deb267b089849b649705e1b72bb1b5b37f7531fd9e0cfb134174f0cb3a8ee2595c7dcf8ce SHA512 839e942bcf8189763d0d9b01614333bb2f036bce68c82959e51d2e9145b57067cb862b66781912391c1a0f531b8dddf2ffeafcee71c626169a437fe40feba155
+DIST dune-3.2.0.tar.gz 1754664 BLAKE2B 97ba420a5bf9dd8e14ba74c0e91b6679924fd9ee7b8d9a9a2d4b282166d9172582a37adf408fd037972dab7525cd240c24729b6692f403c32029b2994044bd40 SHA512 a90ac689d97acab956fd96f16f7c6cfdc95d01785fc14f0d3c8ab39231ff78e8941d2db2fa8cbfaa39bbed8f865e11b628aacae1b22df49512a57d0263c0dca4
diff --git a/dev-ml/dyn/dyn-3.2.0.ebuild b/dev-ml/dyn/dyn-3.2.0.ebuild
new file mode 100644
index 000000000000..2aac9b876c8a
--- /dev/null
+++ b/dev-ml/dyn/dyn-3.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune multiprocessing
+
+DESCRIPTION="Dynamic type"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz
+ -> dune-${PV}.tar.gz"
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+BDEPEND=">=dev-ml/dune-3"
+DEPEND="~dev-ml/ordering-${PV}:=
+ dev-ml/pp:="
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune build -p "${PN}" @install -j $(makeopts_jobs) --profile release || die
+}