summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 13:33:09 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-01 14:24:43 +0200
commit356ff41bb9b806651578b175bd527db99c404d7c (patch)
treeb78af0dd531b157fb5ecb2678e0f57131df46b6b /dev-ml/easy-format/easy-format-1.2.0.ebuild
parentdev-ml/reason: Initial import. Ebuild by me. (diff)
downloadgentoo-356ff41bb9b806651578b175bd527db99c404d7c.tar.gz
gentoo-356ff41bb9b806651578b175bd527db99c404d7c.tar.bz2
gentoo-356ff41bb9b806651578b175bd527db99c404d7c.zip
dev-ml/easy-format: Bump to 1.2.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/easy-format/easy-format-1.2.0.ebuild')
-rw-r--r--dev-ml/easy-format/easy-format-1.2.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/easy-format/easy-format-1.2.0.ebuild b/dev-ml/easy-format/easy-format-1.2.0.ebuild
new file mode 100644
index 000000000000..669c69092068
--- /dev/null
+++ b/dev-ml/easy-format/easy-format-1.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Pretty-printing library for OCaml"
+HOMEPAGE="https://github.com/mjambon/easy-format"
+SRC_URI="https://github.com/mjambon/easy-format/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+
+IUSE="examples +ocamlopt"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake all
+ use ocamlopt && emake opt
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README.md Changes
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}