summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-06-26 09:34:37 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-06-26 09:34:37 +0000
commite2938f0b23783976b6dd1a231cdcabeeb7d71d21 (patch)
treebf14b9011c711a82f4ea8e0b84e919b24ae2dcce /dev-ml/enumerate/enumerate-111.08.00-r1.ebuild
parentdev-ml/camomile: Stable for amd64. Retroactively mark stable for the remainin... (diff)
downloadgentoo-e2938f0b23783976b6dd1a231cdcabeeb7d71d21.tar.gz
gentoo-e2938f0b23783976b6dd1a231cdcabeeb7d71d21.tar.bz2
gentoo-e2938f0b23783976b6dd1a231cdcabeeb7d71d21.zip
dev-ml/enumerate: Fix || operator error and depend on dev-ml/camlp4 only instead.
Gentoo-Bug: https://bugs.gentoo.org/586908 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ml/enumerate/enumerate-111.08.00-r1.ebuild')
-rw-r--r--dev-ml/enumerate/enumerate-111.08.00-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/enumerate/enumerate-111.08.00-r1.ebuild b/dev-ml/enumerate/enumerate-111.08.00-r1.ebuild
new file mode 100644
index 000000000000..568d5b886250
--- /dev/null
+++ b/dev-ml/enumerate/enumerate-111.08.00-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Syntax extension to produce a list of all values of a type"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}.00/individual/${MY_P}.tar.gz
+ https://dev.gentoo.org/~aballier/distfiles/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-ml/type-conv-111.13:=
+ dev-ml/camlp4:="
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+DOCS=( README.md )