summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-10-13 16:24:59 +1100
committerMark Wright <gienah@gentoo.org>2020-10-13 23:53:25 +1100
commitee112288e79ef448ea6ca90381e5829b258fa521 (patch)
treeea96949d0e2d2d93845b0c00d7f3cd6372e41e89 /dev-ml/extlib/extlib-1.7.7.ebuild
parentdev-ml/dune-private-libs: Bump to 2.7.1 (diff)
downloadgentoo-ee112288e79ef448ea6ca90381e5829b258fa521.tar.gz
gentoo-ee112288e79ef448ea6ca90381e5829b258fa521.tar.bz2
gentoo-ee112288e79ef448ea6ca90381e5829b258fa521.zip
dev-ml/extlib: Bump to 1.7.7, try to fix bug 704146
Try to fix bug 704146, thanks to mgorny for reporting. The problem appears to be caused by some change in quoting behaviour of ocamlfind, ocamlc, bash, make or cppo. The quoting insanity is caused by cppo requiring defines on the command line to use quoted spaces, single quotes and double quotes: https://github.com/ocaml-community/cppo/issues/22 Bug: https://bugs.gentoo.org/show_bug.cgi?id=704146 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Mark Wright <gienah@gentoo.org>
Diffstat (limited to 'dev-ml/extlib/extlib-1.7.7.ebuild')
-rw-r--r--dev-ml/extlib/extlib-1.7.7.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-ml/extlib/extlib-1.7.7.ebuild b/dev-ml/extlib/extlib-1.7.7.ebuild
new file mode 100644
index 000000000000..ff4c64b84664
--- /dev/null
+++ b/dev-ml/extlib/extlib-1.7.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib vcs-clean
+
+DESCRIPTION="Standard library extensions for O'Caml"
+HOMEPAGE="https://github.com/ygrek/ocaml-extlib"
+SRC_URI="https://github.com/ygrek/ocaml-extlib/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc +ocamlopt"
+
+RDEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}
+ dev-ml/cppo"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.7-no-git.patch
+ )
+
+S="${WORKDIR}/ocaml-${P}"
+
+src_prepare() {
+ default
+ egit_clean
+}
+
+src_compile() {
+ cd src || die
+ emake -j1 all
+ if use ocamlopt; then
+ emake opt cmxs
+ fi
+
+ if use doc; then
+ emake doc
+ fi
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_install
+
+ # install documentation
+ dodoc README.md
+
+ if use doc; then
+ dodoc -r src/doc/
+ fi
+}