summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-10-13 16:27:41 +1100
committerMark Wright <gienah@gentoo.org>2020-10-13 23:53:26 +1100
commit236f8ac7e1090fef0e4cdfdc27f4fb773416be89 (patch)
tree96dd7fdbe18459a4b04ff6ec928902230c2cd8f8 /dev-ml/findlib/findlib-1.8.1-r1.ebuild
parentdev-ml/fieldslib: Bump to 0.14.0 (diff)
downloadgentoo-236f8ac7e1090fef0e4cdfdc27f4fb773416be89.tar.gz
gentoo-236f8ac7e1090fef0e4cdfdc27f4fb773416be89.tar.bz2
gentoo-236f8ac7e1090fef0e4cdfdc27f4fb773416be89.zip
dev-ml/findlib: EAPI=7
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Mark Wright <gienah@gentoo.org>
Diffstat (limited to 'dev-ml/findlib/findlib-1.8.1-r1.ebuild')
-rw-r--r--dev-ml/findlib/findlib-1.8.1-r1.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/dev-ml/findlib/findlib-1.8.1-r1.ebuild b/dev-ml/findlib/findlib-1.8.1-r1.ebuild
new file mode 100644
index 000000000000..1799cc090907
--- /dev/null
+++ b/dev-ml/findlib/findlib-1.8.1-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib
+
+DESCRIPTION="OCaml tool to find/use non-standard packages"
+HOMEPAGE="http://projects.camlcity.org/projects/findlib.html"
+SRC_URI="http://download.camlcity.org/download/${P}.tar.gz"
+IUSE="doc +ocamlopt tk"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND=">=dev-lang/ocaml-4.08.1-r1:=[ocamlopt?]
+ tk? ( dev-ml/labltk:= )"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/externalmeta7.patch )
+
+src_prepare() {
+ default
+ export ocamlfind_destdir="${EPREFIX}/usr/$(get_libdir)/ocaml"
+ export stublibs="${ocamlfind_destdir}/stublibs"
+}
+
+src_configure() {
+ local myconf
+ use tk && myconf="-with-toolbox"
+ ./configure -bindir "${EPREFIX}"/usr/bin -mandir "${EPREFIX}"/usr/share/man \
+ -sitelib ${ocamlfind_destdir} \
+ -config ${ocamlfind_destdir}/findlib/findlib.conf \
+ -no-custom \
+ ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt # optimized code
+ fi
+}
+
+src_install() {
+ emake prefix="${D}" install
+
+ dodir "${stublibs#${EPREFIX}}"
+
+ if use doc; then
+ cd "${S}/doc" || die
+ dodoc QUICKSTART README DOCINFO
+ docinto html
+ dodoc -r ref-html guide-html
+ fi
+}
+
+check_stublibs() {
+ local ocaml_stdlib=`ocamlc -where`
+ local ldconf="${ocaml_stdlib}/ld.conf"
+
+ if [ ! -e ${ldconf} ]
+ then
+ echo "${ocaml_stdlib}" > ${ldconf}
+ echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
+ fi
+
+ if [ -z `grep -e ${stublibs} ${ldconf}` ]
+ then
+ echo ${stublibs} >> ${ldconf}
+ fi
+}
+
+pkg_postinst() {
+ check_stublibs
+}