summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-15 16:46:46 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-15 16:46:46 +0200
commitf531f8415a1c6d3588248d539a3e7f40329edcef (patch)
tree970bdea0062631e34479f425c6f98305785abf24 /dev-ml/flow_parser/flow_parser-0.50.0.ebuild
parentdev-ml/biniou: bump to 1.1.0 (diff)
downloadgentoo-f531f8415a1c6d3588248d539a3e7f40329edcef.tar.gz
gentoo-f531f8415a1c6d3588248d539a3e7f40329edcef.tar.bz2
gentoo-f531f8415a1c6d3588248d539a3e7f40329edcef.zip
dev-ml/flow_parser: bump to 0.50.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/flow_parser/flow_parser-0.50.0.ebuild')
-rw-r--r--dev-ml/flow_parser/flow_parser-0.50.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/flow_parser/flow_parser-0.50.0.ebuild b/dev-ml/flow_parser/flow_parser-0.50.0.ebuild
new file mode 100644
index 000000000000..a36131a0f030
--- /dev/null
+++ b/dev-ml/flow_parser/flow_parser-0.50.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="JavaScript parser written in OCaml"
+HOMEPAGE="https://github.com/facebook/flow/tree/master/src/parser"
+SRC_URI="https://github.com/facebook/flow/archive/v${PV}.tar.gz -> flow-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/sedlex:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/ocamlbuild"
+
+S="${WORKDIR}/flow-${PV}/src/parser"
+
+src_compile() {
+ emake build-parser
+}
+
+src_test() {
+ emake test-ocaml
+}
+
+src_install() {
+ findlib_src_preinst
+ emake ocamlfind-install
+ dodoc README.md
+}